ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maarten Coene <maarten_co...@yahoo.com>
Subject Re: using ivy for resolving findbugs-1.3.8
Date Wed, 13 May 2009 21:40:42 GMT

You get this error because the maven pom for bcel 1.3.8 is incorrect: it contains "findbugs"
as artifactId while it must be "bcel" instead.

You can configure Ivy to ignore this error by adding checkconsistency="false" to your maven2
resolver in your settings.xml.
Cfr. http://ant.apache.org/ivy/history/2.1.0-rc1/settings/resolvers.html#common

Maarten




----- Original Message ----
From: Giridharan Kesavan <gkesavan@yahoo-inc.com>
To: "ivy-user@ant.apache.org" <ivy-user@ant.apache.org>
Sent: Wednesday, May 13, 2009 4:04:20 PM
Subject: using ivy for resolving findbugs-1.3.8

Hi

I'm trying to get this findbugs dependency resolved using ivy.
And I want to use findbugs-1.3.8 and see that its available through com.google.code.findbugs
http://www.mvnrepository.com/artifact/com.google.code.findbugs

IVY  is able to resolve findbugs-1.3.8 but when It tries to resolve bcel-1.3.8 (which is a
transient dependency for findbugs-1.3.8) it fails with the following error
"
ERROR:    maven2: bad module name found in http://repo1.maven.org/maven2/com/google/code/findbugs/bcel/1.3.8/bcel-1.3.8.pom:
expected='bcel found='findbugs'  "

This is what I have in my ivy.xml file for resolving bcel

<dependency org="com.google.code.findbugs"
      name="bcel"
      rev="1.3.8"
      conf="findbugs"/>

Please help me resolving this

Thanks,
Giri



      

Mime
View raw message