ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bieringer, Dominik" <dbierin...@thegoldensource.com>
Subject RE: Cache not update
Date Tue, 19 May 2009 15:14:00 GMT
I had the same problem. I got it resolved by also updating the publication timestamp in the
ivy.xml file ;).

-----Original Message-----
From: Gilles Sadowski [mailto:gilles@harfang.homelinux.org] 
Sent: Tuesday, May 19, 2009 17:16
To: ivy-user@ant.apache.org
Subject: Re: Cache not update

Hi.

> 
> I have a problem when retrieving artifacts from a filesystem repository. Ivy is always
using the file from the cache even if there is a more recent version in the repository. I
tried several ways to force Ivy to update the cache, but none of them have any effect. Therefore
I assume that this is a bug in ivy. What I tried so far:
> 
> - changing=true on the dependency in ivy.xml
> - checkModified=true on the filesystem resolver in ivysettings.xml
> - changingPattern=".*" on the filesystem resolver
> 
> [...]
>
> As a workaround, I am deleting the cache before every resolve.

I have posted a message reporting this exact same problem. I had tried the
same things, and currently use the same inefficient or error-prone
workaround. Needless to say that I'm also very interested in having this
sorted out (whether bug or feature requiring some appropriate config).

Gilles



Mime
View raw message