ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Logemann ...@logemann.org>
Subject Re: IvyDE: cannot resolve "+" dependency
Date Mon, 11 May 2009 08:57:27 GMT
Hi,

IvyDE version: 2.0.0.beta1
Ivy version: Ivy 2.0.0 - 20090108225011 :: http://ant.apache.org/ivy/ ::

What do you mean with "how the project is resolved?". This is our ANT  
task:

     <target name="ivy.resolve" description="--> retrieve dependencies  
with ivy">
         <ivy:retrieve sync="true" pattern="lib/[type]s/[artifact]- 
[revision].[ext]"/>
     </target>

Which works. And the plugin doesnt but what other infos can we provide?

We use a quite standard settings file, which we pointed IvyDE to:

<ivysettings>
     <settings defaultResolver="public"/>
     <resolvers>
         <ibiblio name="public" m2compatible="true"
                  root="http://ivy.xxxxxxxx.net:8081/nexus/content/groups/public 
"/>
     </resolvers>
</ivysettings>

Dependency:

<dependency org="de.logentis" name="netversyseai-aswo" rev="2.0.+"  
conf="default"/>

Thats all i can provide can i?


---
regards
Marc Logemann
http://www.logemann.org
http://www.logentis.de




Am 09.05.2009 um 10:38 schrieb Nicolas Lalevée:

>
> Le 8 mai 09 à 14:51, Marc Logemann a écrit :
>
>> hmm, tried to put a screenshot in the email but it seems they get  
>> removed. Here the screenshot:
>>
>> http://www.logentis.de/_bitmaps/ivy_problem.jpg
>
> I trust you saying that it doesn't work. My problem here is that I  
> cannot reproduce it, range version with "+" works. But in your use  
> case it doesn't in Eclipse. So could you give more info about how  
> the project is resolved in both Ant and Eclipse ? Which version of  
> Ivy and IvyDE is installed in Eclipse ?
>
> Nicolas
>
>
>
>>
>>
>> ---
>> regards
>> Marc Logemann
>> http://www.logemann.org
>> http://www.logentis.de
>>
>>
>>
>>
>> Am 05.05.2009 um 16:10 schrieb Nicolas Lalevée:
>>
>>> On lundi 4 mai 2009 15:31:45 Marc Logemann wrote:
>>>> Hi,
>>>>
>>>> can it be that IvyDE cant handle a dependency like this one:
>>>>
>>>> <dependency org="de.logentis" name="netversyseai-aswo" rev="2.0.+"
>>>> conf="default"/>
>>>>
>>>> Attention when looking at the "rev" attribute. I used the "+" here
>>>> which seems to be a problem for IvyDE because it complains that it
>>>> cant find 2.0.+
>>>>
>>>> This dependency works nicely with ivy in ANT and also with the IDEA
>>>> ivy plugin...
>>>
>>> As far as I could test, it does work for me with IvyDE 2.0 beta1.
>>> Which version of IvyDE and Ivy are you using in Eclipse ?
>>> Do you use IvyDE's workspace resolver ?
>>>
>>> Nicolas
>>>
>>>>
>>>>
>>>> ---
>>>> regards
>>>> Marc Logemann
>>>> http://www.logemann.org
>>>> http://www.logentis.de
>>>
>>
>


Mime
View raw message