ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Garima Bathla <garima.bat...@gmail.com>
Subject Re: IvyDE: cannot resolve "+" dependency
Date Fri, 08 May 2009 15:52:33 GMT
I am probably going to be funny, but if it helps - can you make sure you do
have module netversyseai-aswo with version 2.0.X ( X - a number) existing? I
wonder what should be the behaviour of Ivy when a particular dependency
couldn't be resolved because the specified revision of the module wasn't
available.


<dependency org="de.logentis" name="netversyseai-aswo" rev="2.0.+"
conf="default"/>
Also if you can try
rev="latest.[any status]" and see if it works? resolves at all?

On Fri, May 8, 2009 at 5:51 AM, Marc Logemann <li@logemann.org> wrote:

> hmm, tried to put a screenshot in the email but it seems they get removed.
> Here the screenshot:
>
> http://www.logentis.de/_bitmaps/ivy_problem.jpg
>
>
> ---
> regards
> Marc Logemann
> http://www.logemann.org
> http://www.logentis.de
>
>
>
>
> Am 05.05.2009 um 16:10 schrieb Nicolas Lalevée:
>
>  On lundi 4 mai 2009 15:31:45 Marc Logemann wrote:
>>
>>> Hi,
>>>
>>> can it be that IvyDE cant handle a dependency like this one:
>>>
>>> <dependency org="de.logentis" name="netversyseai-aswo" rev="2.0.+"
>>> conf="default"/>
>>>
>>> Attention when looking at the "rev" attribute. I used the "+" here
>>> which seems to be a problem for IvyDE because it complains that it
>>> cant find 2.0.+
>>>
>>> This dependency works nicely with ivy in ANT and also with the IDEA
>>> ivy plugin...
>>>
>>
>> As far as I could test, it does work for me with IvyDE 2.0 beta1.
>> Which version of IvyDE and Ivy are you using in Eclipse ?
>> Do you use IvyDE's workspace resolver ?
>>
>> Nicolas
>>
>>
>>>
>>> ---
>>> regards
>>> Marc Logemann
>>> http://www.logemann.org
>>> http://www.logentis.de
>>>
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message