ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Levy-Lambert" <anto...@gmx.de>
Subject Re: ivy:resolve ant task and JAVA_HOME environment variable.
Date Thu, 16 Apr 2009 15:11:27 GMT
Hello Vyacheslav,

I notice that your repository is hosted in a path that your are accessing with an UNC path.


Could you try to mount your repository using a drive letter and see if it helps ? In this
case it would demonstrate that the UNC path is not properly supported. The next step would
be to find out whether the UNC issue is caused by the JDK, by ivy, or by the way you are designating
the UNC path.

Regards,

Antoine

-------- Original-Nachricht --------
> Datum: Thu, 16 Apr 2009 16:36:02 +0400
> Von: "Вячеслав Артюхов" <artyukhovvs@gmail.com>
> An: ivy-user@ant.apache.org
> Betreff: ivy:resolve ant task and JAVA_HOME environment variable.

> ---------- Forwarded message ----------
> From: Вячеслав Артюхов <artyukhovvs@gmail.com>
> Date: 2009/4/16
> Subject: ivy:resolve ant task and JAVA_HOME environment variable.
> To: ivy-user@ant.apache.org
> 
> 
> Good day, gentlemans.
> 
> 
> I have a problem with <ivy:resolve/> ant task.
> I execute my build.xml from command line and behaviour of resolve task
> depends on value of JAVA_HOME environment variable.
> 
> If JAVA_HOME points to java1.4 than ivy downloads revisions in cache.
> If JAVA_HOME points to java1.5 no download is proceed.
> 
> I launched my build.xml a large number times and always, when JAVA_HOME
> points to java1.4 all revisions were downloads to cache and overwrite
> them.
> And always, when JAVA_HOME points to java1.5 no download is proceed.
> 
> Here is my ivysettings.xml
> 
> <ivysettings>
>   <settings defaultResolver="repository" validate="false"/>
> 
> <caches checkUpToDate="false"/>
> 
>   <resolvers>
>     <chain name="repository" changingPattern=".*" checkmodified="true">
>        <filesystem name="myFileSystem" changingPattern=".*"
> checkmodified="true">
>           <ivy
> pattern="\\\\repository/repository/[organisation]/[module]/[revision]/ivy-[revision].xml"
> />
>           <artifact
> pattern="\\\\repository/repository/[organisation]/[module]/[revision]/[artifact]-[revision].[ext]"
> />
>           <artifact
> pattern="\\\\repository/repository/[organisation]/[module]/[revision]/[artifact].[ext]"
> />
>        </filesystem>
>     </chain>
>   </resolvers>
> </ivysettings>
> 
> 
> Here is a part of code in my build.xml:
> 
>     <ivy:settings file="${ivy.settings.dir}/ivysettings.xml" />
>     <ivy:resolve file="${root.dir}/ivy.xml" refresh="true"/>
>     <ivy:retrieve pattern="${root.dir}/../[type]/[artifact].[ext]"/>
> 
> I'm sure, all properties ivy.settings.dir, root.dir are correctly set.
> 
> Vyacheslav Artyukhov
> 
> 
> 
> -- 
> Вячеслав Артюхов.

Mime
View raw message