ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée <nicolas.lale...@hibnet.org>
Subject Re: No Ivy jar in IvyDE?
Date Wed, 18 Mar 2009 09:13:17 GMT
On mardi 17 mars 2009 16:37:50 Daniel Dekany wrote:
> Tuesday, March 17, 2009, 3:38:08 PM, Becheanu, Daniel wrote:
> > I don't think IvyDE is suppose to install anything in ant classpath
> > within eclipse.
>
> But maybe the maintainers of IvyDE should publish a separate plugin
> ("IvyAnt" or something) within the same "site" that does that. That
> would prevent the surprises (since most users just check the top-level
> node of the site in the Eclipse installer, hence grab all the
> plugins), also then user could benefit from the Eclipse plugin
> installer/updater facility.

IvyDE 1.4 used to install ivy in Eclipse's ant classpath, but at that time Ivy 
was bundle into IvyDE. Now that IvyDE and Ivy are packaged as separated OSGi 
bundles, it is not possible to make Eclipse add the Ivy bundle to the ant 
classpath, it has to be "overpackaged" (Eclipse needs a jar of a jar).
Then as you suggest, a new plugin would be needed. You are welcomed to open a 
jira issue about it :).

Nicolas


>
> > Daniel
> >
> > -----Original Message-----
> > From: Geoff Ballinger [mailto:geoff-list@mobileacuity.com]
> > Sent: Tuesday, March 17, 2009 9:33 AM
> > To: ivy-user@ant.apache.org
> > Subject: No Ivy jar in IvyDE?
> >
> >         As far as I can tell the Ivy plugin does not correctly install
> > the Ivy jar into the Ant classpath within eclipse - needed to put it in
> > manually after the install. I guess this is probably a bug or am I
> > missing something? Thanks!,
> >
> >                                 Geoff.


Mime
View raw message