ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mikko Nylén <>
Subject Re: Problem with Hibernate
Date Fri, 27 Feb 2009 10:56:27 GMT

I noticed that too.

However, when I was reading Harnessing Hibernate from O'Reilly there was
something about javax.transaction.jta being non-free and thus it wouldn't be
available from the Maven repositories. The solution seems to be excluding
organizations and javax.transaction when specifying
hibernate-core as dependency and then adding a dependency to
org.apache.geronimo.specs#geronimo-jta_1.1_spec. My ivy.xml now looks like


<ivy-module version="2.0">

        <dependency org="junit" name="junit" rev="4.5" />

        <dependency org="org.apache.geronimo.specs"
name="geronimo-jta_1.1_spec" rev="1.1.1" />

        <dependency org="org.hibernate" name="hibernate-core" rev="3.3.1.GA
            <exclude org="javax.transaction" />
            <exclude org="" />

        <dependency org="org.hibernate" name="hibernate-tools" rev=""


This seems to be working fine. At least, I dont get errors during

- Mikko Nylén

2009/2/27 Lee Theobald <>

> I'm getting the same error Nikko.  I don't think it's you or me though.
> Taking a look at contents of the repository
> (, the jar files mentioned
> in
> the output don't exist at the locations I believe they should.
> Have the jar files been removed for some reason? Do we need to link to
> another repository?
> The page for the JACC artifact also have a link to a jar file that doesn't
> exist any more:
> Lee,
> --
> View this message in context:
> Sent from the ivy-user mailing list archive at

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message