ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Schl├Ąpfer <Andreas.Schlaep...@crealogix.com>
Subject IvyDE and Eclipse 3.3: Missing plugin error
Date Tue, 17 Feb 2009 16:50:30 GMT
Hi

I tried to install the latest IvyDE on an a clean Eclipse 3.3.2 installation. 
Now the feature org.apache.ivy.feature reports the error:
Plug-in "org.apache.ivy" version "2.0.0.final" referenced by this feature is 
missing.

In an older post there are some hints about the error cause:
http://www.nabble.com/Error-in-org.apache.ivy-plugin-MANIFEST--td21579462.html

In the file eclipse\features\org.apache.ivy.feature_2.0.0.final\feature.xml 
the version '2.0.0.final'

   <plugin
         id="org.apache.ivy"
         download-size="0"
         install-size="0"
         version="2.0.0.final"
         unpack="false"/>

should be changed to

   <plugin
         id="org.apache.ivy"
         download-size="0"
         install-size="0"
         version="2.0.0.final_20090108225011"
         unpack="false"/>

With that change it works ok. The name of the jar doesn't make a difference 
(org.apache.ivy_2.0.0.final.jar or 
org.apache.ivy_2.0.0.final_20090108225011.jar works).
Maybe that should be fixed on the update site...

Regards, Andi

*****
Eclipse: 3.3.2
Update Site: http://www.apache.org/dist/ant/ivyde/updatesite

BTW: It's installing without problems on my Eclipse 3.4.1 installation.

Mime
View raw message