ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kent Larsson <kent.lars...@gmail.com>
Subject Get all necessary dependencies for Hibernate with annotations to work (by default, it seems dependencies are missing.)
Date Fri, 06 Feb 2009 14:35:39 GMT
Hi,

I have trouble getting Hibernate with annotations to work. I'm using
the default repository (ibiblio in maven2 mode) and I'm missing
javassist which results in a ClassNotFoundException when I run my
program.

In the POM-file for hibernate-core (
http://mirrors.ibiblio.org/pub/mirrors/maven2/org/hibernate/hibernate-core/3.3.1.GA/hibernate-core-3.3.1.GA.pom
) there are some lines which I'm wondering about:

    <dependencies>
        ...
        ...
        ...
        <!-- optional deps for bytecode providers until those are
finally properly scoped -->
        <dependency>
            <groupId>javassist</groupId>
            <artifactId>javassist</artifactId>
            <version>3.4.GA</version>
            <optional>true</optional>
        </dependency>
        <dependency>
            <groupId>org.hibernate</groupId>
            <artifactId>hibernate-cglib-repack</artifactId>
            <version>2.1_3</version>
            <optional>true</optional>
        </dependency>
    </dependencies>

What do they mean with until those are finally properly scoped? I need
javassist to run my very basic Hibernate annotations application, and
actually I think I need cglib as well. How do I get these optional
dependencies? (Which really doesn't seem that optional at all.)

My ivy.xml:

<?xml version="1.0" encoding="UTF-8"?>
<ivy-module version="2.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:noNamespaceSchemaLocation="http://ant.apache.org/ivy/schemas/ivy.xsd">
	<info
	  organisation="testorganization"
	  module="hibernatetest"
	  status="integration"/>
	<configurations>
		<conf name="runtime" description="" />
	</configurations>
	<dependencies>
		<dependency org="mysql" name="mysql-connector-java" rev="5.1.6"
conf="runtime->default"/>
		<dependency org="org.hibernate" name="hibernate-core" rev="3.3.1.GA"
conf="runtime->default"/>
		<dependency org="org.hibernate" name="hibernate-annotations"
rev="3.4.0.GA" conf="runtime->default">
			<include></include>
		</dependency>
		<dependency org="org.slf4j" name="slf4j-log4j12" rev="1.5.6"
conf="runtime->default"/>
	</dependencies>
</ivy-module>

Should I not use "->default"? Is there something I can add to say that
I want both of these "optional" dependencies? Has anyone got any idea
why they were set as optional in the first place?


Best regards, Kent

Mime
View raw message