ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée <nicolas.lale...@hibnet.org>
Subject Re: IvyDE and Eclipse 3.3: Missing plugin error
Date Wed, 18 Feb 2009 14:46:29 GMT
On mardi 17 février 2009 17:50:30 Andreas Schläpfer wrote:
> Hi
>
> I tried to install the latest IvyDE on an a clean Eclipse 3.3.2
> installation. Now the feature org.apache.ivy.feature reports the error:
> Plug-in "org.apache.ivy" version "2.0.0.final" referenced by this feature
> is missing.
>
> In an older post there are some hints about the error cause:
> http://www.nabble.com/Error-in-org.apache.ivy-plugin-MANIFEST--td21579462.h
>tml
>
> In the file eclipse\features\org.apache.ivy.feature_2.0.0.final\feature.xml
> the version '2.0.0.final'
>
>    <plugin
>          id="org.apache.ivy"
>          download-size="0"
>          install-size="0"
>          version="2.0.0.final"
>          unpack="false"/>
>
> should be changed to
>
>    <plugin
>          id="org.apache.ivy"
>          download-size="0"
>          install-size="0"
>          version="2.0.0.final_20090108225011"
>          unpack="false"/>
>
> With that change it works ok. The name of the jar doesn't make a difference
> (org.apache.ivy_2.0.0.final.jar or
> org.apache.ivy_2.0.0.final_20090108225011.jar works).
> Maybe that should be fixed on the update site...

We are in the way of fixing it, the updatesite will be better generated.
See also https://issues.apache.org/jira/browse/IVYDE-156

Nicolas


Mime
View raw message