ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée <nicolas.lale...@hibnet.org>
Subject Re: IvyDE 2.0.0.beta1 does not download sources nor javadocs
Date Wed, 11 Feb 2009 15:44:51 GMT
On mardi 10 février 2009 21:01:01 Dmitriy Korobskiy wrote:
> Hi, all
>
> I have a slightly different issue - IvyDE is downloading sources, but
> Javadocs do not work for the life of me.
> I had that issue a year and a half ago with IvyDE 1.2, and it seems now
> as a resurgence of closed IvyDE-55:
> https://issues.apache.org/jira/browse/IVYDE-55.
>
> I'm using Eclipse 3.4.1 platform (IBM RAD 7.5.1 distribution) and IvyDE
> 2.0.0.beta1. The difference with your, Gael, configuration from what I
> understood could be that I declare all artifacts explicitly in ivy.xml.
>
> Here are the steps.
> 1. ivy.xml
> <?xml version="1.0"?>
> <?xml version="1.0"?>
> <ivy-module version="2.0"
>   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:noNamespaceSchemaLocation="http://ant.apache.org/ivy/schemas/ivy.xsd">
>   <info organisation="xxx" module="mmm" status="integration" />
>   <configurations>
>     <conf name="compile" />
>     <conf name="war" /> <!-- Artifacts to be included in a WAR -->
>     <conf name="ide" extends="compile" description="+ Javadocs and
> sources" />
>   </configurations>
>   <dependencies defaultconf="compile,war->default;ide->ide(default)">
>     <dependency org="apache" name="commons-logging" rev="1.1"/>
>   </dependencies>
> </ivy-module>
>
> 2. Repository files:
> {repository}\apache\commons-logging\commons-logging-1.1\commons-logging-1.1
>-doc.zip
> {repository}\apache\commons-logging\commons-logging-1.1\commons-logging-1.1
>-src.zip
> {repository}\apache\commons-logging\commons-logging-1.1\commons-logging-1.1
>.jar
>
> 3. commons-logging-1.1-ivy.xml
> <?xml version="1.0"?>
> <?xml-stylesheet type="text/xsl"
> href="http://ivyrep.jayasoft.org/ivy-doc.xsl"?>
> <ivy-module version="2.0"
>   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:noNamespaceSchemaLocation="http://ant.apache.org/ivy/schemas/ivy.xsd">
>   <info organisation="apache" module="commons-logging" revision="1.1"
> status="release"/>
>   <configurations>
>     <conf name="default"/>
>     <conf name="ide" extends="default" description="JavaDoc and sources"/>
>   </configurations>
>   <publications>
>     <artifact name="commons-logging-1.1" type="jar" conf="default"/>
>     <artifact name="commons-logging-1.1-src" type="source" ext="zip"
> conf="ide"/>
>     <artifact name="commons-logging-1.1-doc" type="javadoc" ext="zip"
> conf="ide"/>
>   </publications>
> </ivy-module>
>
> I get commons-logging-1.1.jar with an attached source, but not Javadocs.

I have some similar configuration to yours. Looking into the properties of the 
jar in the IvyDE container, they look good. But me too the javadoc view tells 
me that nothing is attached.
I then setup an non-Ivy project, with a jar and some attached javadoc. Eclipse 
tells me that it looks good ("Validate..." button). But the javadoc view still 
tell me that nothing is attached... Am I missing something here ? Could you 
try to setup some simple non-Ivy project and tells me if it works ? And if it 
works post your .classpath ?

Nicolas



Nicolas




>
> Marziou, Gael wrote:
> >> I think you are hitting this issue:
> >> https://issues.apache.org/jira/browse/IVYDE-146
> >
> > Merci Nicolas, the description matches indeed.
> >
> > But in this case I don't understand why I still have the issue with trunk
> > build #20 IvyDE-updatesite on Hudson server, this fix is supposed to be
> > included.
> >
> > Gael


Mime
View raw message