ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Xavier Hanin <xavier.ha...@gmail.com>
Subject Re: Latest IvyDE fails to resolve dependencies under Eclipse 3.4
Date Mon, 26 Jan 2009 17:02:44 GMT
On Mon, Jan 26, 2009 at 4:58 PM, Bagwell, Allen F <afbagwe@sandia.gov>wrote:

>
> My team has been using IvyDE in Eclipse 3.3 for some time now with IvyDE 2
> alpha 1.
>
> Today I am trying to set up Eclipse 3.4, and upon installing the latest
> IvyDE and attempting to open an IvyDE-equipped project I keep getting the
> message:
>
> "Impossible to resolve dependencies of... Resolve project 'Arbit' and ivy
> file 'ivy.xml' dependencies"
>
> then it gives me a list of unresolved dependencies... which is basically
> everything.
>
> Specifically here is the error message...
>
> Impossible to resolve dependencies of arbit#
> Arbiter;working@cloudnine.sandia.gov<Arbiter%3Bworking@cloudnine.sandia.gov>
>  unresolved dependency: junit.org#junit;${junit.version}: not found
>  unresolved dependency: jboss#drools;${drools.version}: not found
>  unresolved dependency: apache#commons-cli;${commons-cli.version}: not
> found
>  unresolved dependency: apache#log4j;${log4j.version}: not found
>  unresolved dependency: synch#synch-time;${synch-time.version}: not found
>  unresolved dependency: msgs#msgdef;${msgdef.version}: not found
>
> And here is the dependencies section of my ivy file:
>
>
> <dependencies>
>        <dependency org="junit.org" name="junit" rev="${junit.version}" />
>        <dependency org="jboss" name="drools" rev="${drools.version}" />
>        <dependency org="apache" name="commons-cli"
> rev="${commons-cli.version}" />
>        <dependency org="apache" name="log4j" rev="${log4j.version}" />
>        <dependency org="synch" name="synch-time"
> rev="${synch-time.version}" conf="*"/>
>        <dependency org="msgs" name="msgdef" rev="${msgdef.version}" />
> </dependencies>
>
> This ivy file works under Eclipse 3.3 and IvyDE 2-alpha 1.
>
> Under Eclipse 3.4 and IvyDE 2-beta 1, the dependency error shows up.
>
> Running my ant resolve task from the command line in the project directory
> ("ant resolve -v"), Ivy2.0 has absolutely no problems with the ivy.xml file.
>
> Any suggestions as to what is going wrong?

Are you sure your settings are the same? It seems Ivy can't find the
properties value in IvyDE.

Xavier


>
>
>
> Allen F. Bagwell
> e-mail:  afbagwe@sandia.gov
> phone:  505/284-4517
> fax:  505/ 844-7886
>
>
> Ask your doctor if medical advice from a TV commercial is right for you.
>
>
>
>


-- 
Xavier Hanin - 4SH France
BordeauxJUG co leader - http://www.bordeauxjug.org/
Blogger - http://xhab.blogspot.com/
Apache Ivy Creator - http://ant.apache.org/ivy/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message