ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Matzon <mat...@certus.dk>
Subject Re: unable to install - broken since rc1
Date Tue, 27 Jan 2009 15:23:04 GMT
Kent Larsson wrote:
> Which Ivy version do you use? If it's not the final one, upgrade.
>   
all versions since rc1 dont work - I tried them all.
> If you upgraded, did you clean your cache afterwards? If you didn't, try it.
>   
cache, local all of it cleaned
> Is overwrite set to false? If yes, can you set it to true? If it's set to
> false and the destination exists I guess it's acting as it should.
>   
It shouldn't even be overwriting, so setting this to true should be the 
solution.
However, I have now tried setting this to true - and it works. However 
notice the following:
[ivy:install]   published logback-classic to 
local/ch.qos.logback/logback-classic/trunk/logback-classic-0.9.8.jar                     
                                                              

[ivy:install]   published logback-classic to 
local/ch.qos.logback/logback-classic/trunk/logback-classic-0.9.8.jar                     
                                                              

[ivy:install]   published ivy to 
local/ch.qos.logback/logback-classic/trunk/ivy-0.9.8.xml
For some odd reason, Ivy is installing it *twice
*This may be related to it trying to install both source and normal jar 
- with the same name - and my artifact pattern not having (-[type]) in it?

However, it didn't even download the source jar in beta2 ?
**
> Are you able to overwrite the destination file yourself? If you are not,
> maybe a process is using it or you have a file permission problem. In any
> case, if you can't delete it and Ivy is running from your account, then you
> need to fix something so that you (and Ivy) are able to delete it.
>   
My solution so far, have been to install it into my repo using beta 2 
and then use that from ivy2 final.

-- 
Brian Matzon
Certus


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message