ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kirby Files <>
Subject Re: sftp.keyFile must be absolute
Date Tue, 20 Jan 2009 16:18:04 GMT
Brian Matzon wrote on 01/19/2009 05:15 AM:
> I recently updated from beta 2 to rc2 and I was unable to run ivy 
> because sftp.keyFile is now required to be absolute.

> fwiw, it would be nice if SFTPResolver waited to initialize (and fail) 
> until its actually used?

Yes, I was bummed that rc2 broke all of my ivy configs as well. Not 
only the above problem (as you say, why fail so early, even if the 
resolver isn't used?); I also had to update all of my configs which 
used <ivy:settings override="true"/>. It was required in my configs 
prior to rc2, and illegal after rc2, so none of my ivy settings are 
backwards or forwards compatible. A real flag day!

Kirby Files
Software Architect
Masergy Communications

View raw message