ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Roberts" <jrobe...@rjlg.com>
Subject Can't use dynamic versions in dependencies.
Date Mon, 26 Jan 2009 19:07:37 GMT
Hello,

I'm an ivy noob and can't seem to get the dependencies to resolve
version numbers using the latest.[status] way.

Seems like the docs for 2.0 are incorrect
<dependency name="axis2-war" revision="latest.release"
conf="test->default"/>  
Will give me an error because the revsision tag is not supported.

I've tried <dependency name="axis2-war" rev="latest.release"
conf="test->default"/>  

But it doesn't appear to be trying any actual revision numbers it gives
me this in the error log

[ivy:resolve] 	==== Ivy-Nexus: tried
[ivy:resolve]
http://aaronsiri-lt-2:8080/nexus/content/groups/public/apache/axis2-war/
latest.release/ivy.xml
[ivy:resolve]
http://aaronsiri-lt-2:8080/nexus/content/groups/public/apache/axis2-war/
[revision]/ivy.xml
[ivy:resolve] 	  -- artifact
apache#axis2-war;latest.release!axis2-war.jar:
[ivy:resolve]
http://aaronsiri-lt-2:8080/nexus/content/groups/public/apache/axis2-war/
latest.release/axis2-war.jar
[ivy:resolve]
http://aaronsiri-lt-2:8080/nexus/content/groups/public/apache/axis2-war/
[revision]/axis2-war.jar


Thanks,
Jon Roberts

Mime
View raw message