ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maarten Coene <maarten_co...@yahoo.com>
Subject Re: Ivy Errors on Retrieve
Date Tue, 02 Dec 2008 07:42:38 GMT
This problem should have been fixed in release 2.0-RC2.
What version of Ivy do you use?

Maarten




----- Original Message ----
From: Tyler Kocheran <rfkrocktk@gmail.com>
To: ivy-user@ant.apache.org
Sent: Tuesday, December 2, 2008 6:41:54 AM
Subject: Ivy Errors on Retrieve

I'm kind of new to using Ivy, and I have been having problems doing somewhat
simple tasks in Ivy. I'm trying to download Apache Mina from the default
repository. My ivy.xml file looks as so:
<ivy-module version="2.0">
    <info organisation="tkassembled" module="mina-server"/>
    <dependencies>
        <dependency org="org.apache.mina" name="mina-core" rev="2.0.0-M3"/>
    </dependencies>
</ivy-module>

If I change the dependency to something else such as the "commons-lang"
library, I get no errors. Here is the error I am getting:
[ivy:resolve] :: problems summary ::
[ivy:resolve] :::: WARNINGS
[ivy:resolve]         [FAILED     ]
org.apache.mina#mina-core;2.0.0-M3!mina-core.bundle:  (0ms)
[ivy:resolve]     ==== shared: tried
[ivy:resolve]       C:\Documents and
Settings\tk\.ivy2/shared/org.apache.mina/mina-core/2.0.0-M3/bundles/mina-core.bundle
[ivy:resolve]     ==== public: tried
[ivy:resolve]
http://repo1.maven.org/maven2/org/apache/mina/mina-core/2.0.0-M3/mina-core-2.0.0-M3.bundle
[ivy:resolve]         ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]         ::              FAILED DOWNLOADS            ::
[ivy:resolve]         :: ^ see resolution messages for details  ^ ::
[ivy:resolve]         ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]         :: org.apache.mina#mina-core;2.0.0-M3!mina-core.bundle
[ivy:resolve]         ::::::::::::::::::::::::::::::::::::::::::::::

As per the Quick Start tutorial, I looked up the dependency on the
mvnrepository.com website, it is listed as so:
<dependency>
     <groupId>org.apache.mina</groupId>
    <artifactId>mina-core</artifactId>
    <version>2.0.0-M3</version>
</dependency>

Is there something I'm doing wrong?

Thanks,
- TK

-- 
And do this, knowing the time, that now it is high time to awake out of
sleep;
for now our salvation is nearer than when we first believed.



      

Mime
View raw message