ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Clements Mark" <cleme...@OFAC.CH>
Subject RE: Now Ivy RC2 is there a plan to add an IvyDE compatible version?
Date Thu, 27 Nov 2008 14:41:55 GMT
> I have just build a candidate to be released this morning [1], so
unless
> there are vetos, the next beta will be officially released next week.
> 
> Nicolas
> 
> [1] http://marc.info/?l=ant-dev&m=122778029204470&w=2
> 
Hi Nicolas,
Thanks for the new beta. Although I can install it by unpacking the jars
manually, I am still unable to install in RAD 7 using the updatesite
(http://people.apache.org/~hibou/staging/updatesite/). Ivy 2.0.0.cr2
installs fine (if I deselect IvyDE), but the IvyDE update fails. The
error log contains (apologies for the wrapping):

!ENTRY org.eclipse.update.core 4 0 2008-11-27 15:14:42.712
!MESSAGE Error retrieving
"plugins/org.apache.ivyde.eclipse_2.0.0.beta1.jar". [Error opening zip
file
C:\DOCUME~1\clements\LOCALS~1\Temp\eclipse\.update\1227795262540\1227795
262542\eclipse28296.tmp]
!STACK 0
java.util.zip.ZipException: Error opening zip file
C:\DOCUME~1\clements\LOCALS~1\Temp\eclipse\.update\1227795262540\1227795
262542\eclipse28296.tmp
	at java.util.zip.ZipFile.open(Native Method)
	at java.util.zip.ZipFile.<init>(Unknown Source)
	at java.util.jar.JarFile.<init>(Unknown Source)
	at java.util.jar.JarFile.<init>(Unknown Source)
	at
org.eclipse.update.internal.jarprocessor.JarProcessor.processJar(Unknown
Source)
	at
org.eclipse.update.internal.core.FeaturePackagedContentProvider.retrieve
LocalJar(Unknown Source)
	at
org.eclipse.update.internal.core.FeaturePackagedContentProvider.getPlugi
nEntryArchiveReferences(Unknown Source)
	at
org.eclipse.update.internal.operations.UpdateUtils.downloadFeatureConten
t(Unknown Source)
	at
org.eclipse.update.internal.ui.wizards.InstallWizard2.download(Unknown
Source)
	at
org.eclipse.update.internal.ui.wizards.InstallWizard2.access$3(Unknown
Source)
	at
org.eclipse.update.internal.ui.wizards.InstallWizard2$3.run(Unknown
Source)
	at org.eclipse.core.internal.jobs.Worker.run(Unknown Source)

!ENTRY org.eclipse.core.runtime 8 1 2008-11-27 15:14:44.290
!MESSAGE

I can successfully install other features and plugins (Findbugs, PMD,
subclipse, an in-house plugin). The problem is probably due to some
foible of RAD 7, but I thought you should be made aware of it in any
case. I'm aware that RAD 7.5 is a different beast altogether, but we
aren't in a position to migrate to that just yet.

Thanks again,

Mark

Mime
View raw message