ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Goldspink, Matt \(IT\)" <Matthew.Goldsp...@morganstanley.com>
Subject RE: Now Ivy RC2 is there a plan to add an IvyDE compatible version?
Date Tue, 11 Nov 2008 08:44:59 GMT
Hi Nicholas,

Thanks for the reply.

> Actually the new version of Ivy is already deployed in the IvyDE updatesite, you can
update it.

It looks like Ivy RC2 is misspelt on the update site:

<feature url="features/org.apache.ivy.feature_2.0.0.cr2.jar" id="org.apache.ivy.feature"
version="2.0.0.cr2">

This caused an issue in Eclipse 3.4 because we'd had a previous version of ivy installed which
was spelt correctly (i.e. 2.0.0.rc1) and now Eclipse seems to think 2.0.0.cr2 is older and
won't update without an uninstall. I assume its doing basic ascii comparison and 'r' being
greater than 'c' is causing it to fail.

> Note that the current implementation of the "resolve in workspace"
> feature is quite experimental, not very clean, but is a first step towards a correct
implementation. So use it with caution.

My team (15 globally) have been using this feature across a workspace of 20 interdependent
projects and so far, aside from patches we have submitted, we have not had any issues. If
any changes are made to the implementation I'd be happy to test them out since they will probabbly
have a big impact on our team.

> But yes it is time to think about an IvyDE release, I will start a discussion on the
dev mailing list.

Great! I'll keep an eye out for any updates.

Thanks,
Matt

-----Original Message-----
From: Nicolas Lalevée [mailto:nicolas.lalevee@hibnet.org]
Sent: 10 November 2008 21:47
To: ivy-user@ant.apache.org
Subject: Re: Now Ivy RC2 is there a plan to add an IvyDE compatible version?


Le 10 nov. 08 à 18:01, Goldspink, Matt (IT) a écrit :

> Hi,
>
> Now that Ivy RC2 is out is it possible to get an IvyDE compatible
> version added to the IvyDE update site?

Actually the new version of Ivy is already deployed in the IvyDE updatesite, you can update
it. The current released version of IvyDE
(2.0.0.alpha1) is compatible with it.

> We'd like to use some of the new features like Resolving in Workspace,
> in the past we've been taking a cut of the source code and using that,
> but it would be nice if the official update site could provide us with
> a compatible version.

Note that the current implementation of the "resolve in workspace"
feature is quite experimental, not very clean, but is a first step towards a correct implementation.
So use it with caution.

> Is there any date we can expect one by?

No date scheduled by now.
But yes it is time to think about an IvyDE release, I will start a discussion on the dev mailing
list.

Nicolas
--------------------------------------------------------

NOTICE: If received in error, please destroy and notify sender. Sender does not intend to
waive confidentiality or privilege. Use of this email is prohibited when received in error.

Mime
View raw message