ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeffrey Fredrick" <jeffrey.fredr...@gmail.com>
Subject Re: hello-ivy getting javadoc jar instead of jar with .class files
Date Fri, 17 Oct 2008 07:44:41 GMT
Just wanted to mention that a recent checkin fixed the problem
building the head.

Jtf

On Mon, Oct 13, 2008 at 6:51 AM, Becheanu, Daniel <dbecheanu@cars.com> wrote:
> Hi,
>
> Is a fix in main line for that.
> But as a fix for rc1
> Set this properties into your build.properties
>
> ivy.retrieve.pattern = ${ivy.lib.dir}/[artifact]-[revision](-[classifier]).[ext]
> ivy.deliver.ivy.pattern = ${ivy.distrib.dir}/[type]s/[artifact]-[revision](-[classifier]).[ext]
> ivy.publish.src.artifacts.pattern = ${ivy.distrib.dir}/[type]s/[artifact]-[revision](-[classifier]).[ext]
>
> This solved the problem for me.
>
> Daniel
>
> -----Original Message-----
> From: Jeffrey Fredrick [mailto:jeffrey.fredrick@gmail.com]
> Sent: Monday, October 13, 2008 12:27 AM
> To: ivy-user@ant.apache.org
> Subject: hello-ivy getting javadoc jar instead of jar with .class files
>
> I'm having trouble getting started here...
>
> I downloaded rc1 and copied the ivy jar to my ant lib.  But when I try
> and run hello-ivy I get a compile failure because Ivy has delivered me
> the commons-cli java doc jar rather than the classes jar.
>
> I checked the mailing list and JIRA but I don't see anyone else with
> this problem.  Is it just me?  What can I do differently?
>
> Perhaps related, I also fail when trying to compile the latest Ivy
> source from Subversion on my machine. Running the build I get the
> following JUnit failures:
>
> IBiblioResolverTest
>  testErrorReport : Error: SAXParseException: Element type
> "bannersizes.length" must be followed by either attribute
> specifications, ">" or "/>".
>  testUnknown : Failure : Line 335
>
> URLResolverTest
>  testLatestIBiblio : Failure : Line 263
>  testVersionRangeIBiblio : Failure : Line 284
>  testUnknown: Error : java.text.ParseException: [xml parsing:
> ivy-1.0.xml.original:3:7: cvc-elt.1: Cannot find the declaration of
> element 'html'. in
> file:/Users/jfredrick/projects/ivy/build/cache/unknown/unknown/ivy-1.0.xml.original
> , unknown tag html in
> file:/Users/jfredrick/projects/ivy/build/cache/unknown/unknown/ivy-1.0.xml.original
> , unknown tag head in
> file:/Users/jfredrick/projects/ivy/build/cache/unknown/unknown/ivy-1.0.xml.original
> , unknown tag title in
> file:/Users/jfredrick/projects/ivy/build/cache/unknown/unknown/ivy-1.0.xml.original
> , unknown tag meta in
> file:/Users/jfredrick/projects/ivy/build/cache/unknown/unknown/ivy-1.0.xml.original
> , unknown tag meta in
> file:/Users/jfredrick/projects/ivy/build/cache/unknown/unknown/ivy-1.0.xml.original
> , unknown tag meta in
> file:/Users/jfredrick/projects/ivy/build/cache/unknown/unknown/ivy-1.0.xml.original
> ]
>
> Help?
>
> I'm on OS X using Java 5 and Ant 1.7.
>
> Jtf
>
> --
> http://blog.jeffreyfredrick.com
>



-- 
http://blog.jeffreyfredrick.com

Mime
View raw message