ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brown, Carlton" <Carlton.Br...@compucredit.com>
Subject RE: Force attribute not implemented on standard resolvers?
Date Wed, 08 Oct 2008 21:18:00 GMT
Attached debug output.

We only started using Ivy at beta2, so we would not have any older
version anywhere on the classpath.  This happens with both beta2 and
rc1, the failure is the same in either case. 

-----Original Message-----
From: Maarten Coene [mailto:maarten_coene@yahoo.com] 
Sent: Wednesday, October 08, 2008 4:22 PM
To: ivy-user@ant.apache.org
Subject: Re: Force attribute not implemented on standard resolvers?

Could you please verify that you don't have an older version of Ivy
somewhere in your classpath?
If you don't use an older version, could you run again with the -d
option and post the output generated by Ivy?

Maarten




----- Original Message ----
From: "Brown, Carlton" <Carlton.Brown@compucredit.com>
To: ivy-user@ant.apache.org
Sent: Wednesday, October 8, 2008 10:16:36 PM
Subject: RE: Force attribute not implemented on standard resolvers?

I've attached a truncated version with internal company information
stripped out.   But the fragment needed to reproduce the problem is:


<filesystem name="local-staging" force="true" m2compatible="true"
checkmodified="true" transactional="auto" local="true">
    <ivy
pattern="${ivy.local.default.root}/local-staging/[organisation]/[module]
/[revision]/ivy.xml" />
      <artifact
pattern="${ivy.local.default.root}/local-staging/[organisation]/[module]
/[revision]/[artifact].[ext]" />
</filesystem>

This gives me the ParseException each time, either on beta2 or rc1.  If
I remove only the force="true" attribute assignment, there is no
problem.

-----Original Message-----
From: Maarten Coene [mailto:maarten_coene@yahoo.com]
Sent: Wednesday, October 08, 2008 3:56 PM
To: ivy-user@ant.apache.org
Subject: Re: Force attribute not implemented on standard resolvers?

I don't have problems setting the force attribute.
The following construct doesn't give an error for me:

<filesystem name="local" force="true">
    ...
</filesystem>

Could you post your ivy-settings-common.xml here?

Maarten




----- Original Message ----
From: "Brown, Carlton" <Carlton.Brown@compucredit.com>
To: ivy-user@ant.apache.org
Sent: Wednesday, October 8, 2008 9:37:15 PM
Subject: Force attribute not implemented on standard resolvers?

According to the docs, the standard resolvers can be configured with a
"force" attribute.   But when I try to assign the attribute I get this
message:

java.text.ParseException: failed to load settings from
file:\\ivy-settings-common.xml: no set method found for force on class
org.apache.ivy.plugins.resolver.FileSystemResolver

I think FileSystemResolver is a standard resolver, and I did follow the
doc correctly.  This happened both on beta2 and rc1.

Thanks,
Carlton



-----------------------------------------
====================================================
This message contains PRIVILEGED and CONFIDENTIAL information that is
intended only for use by the named recipient. If you are not the named
recipient, any disclosure, dissemination, or action based on the
contents of this message is prohibited. In such case please notify us
and destroy and delete all copies of this transmission.  Thank you.
====================================================


      

Mime
View raw message