ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ryan cheng" <ryan.h...@gmail.com>
Subject use url resolver with https Authentication error
Date Thu, 16 Oct 2008 03:26:01 GMT
Hi all:
I want use url resolver get the dependencied jar from a repo.
here is the build file:
ivysettings.xml:

<ivysettings>
  <settings defaultResolver="chained"/>
  <resolvers>
    <chain name="chained" returnFirst="true">
      <filesystem name="libraries">
        <artifact
pattern="${basedir}/${include.lib.dir}/[artifact]-[revision].[type]" />
      </filesystem>
      <url name="hs">
        <artifact pattern="
https://cm.hd.com:8899/head-develop/dist/[artifact]-[revision].[ext]" />
      </url>

    </chain>
  </resolvers>
</ivysettings>

build.xml:
    <target name="init-ivy"  >
      <ivy:configure   host="cm.hd.com:8899" username="hd\myname"
passwd="password"  />
      <ivy:settings file="${ivy.settings.file}" />
      <ivy:retrieve />
    </target>

but i got failed! here is the build message:


standard:

init-ivy:
[ivy:configure] :: Ivy 2.0.0-rc1 - 20080916082609 ::
http://ant.apache.org/ivy/ ::
:: loading settings :: file = E:\eclipse\3.3\ws\Antenna\ivysettings.xml
[ivy:retrieve] :: resolving dependencies ::
com.hd#tzyj;working@e2d178541d40466
[ivy:retrieve]     confs: [default]
[ivy:retrieve] :: resolution report :: resolve 1168ms :: artifacts dl 0ms
    ---------------------------------------------------------------------
    |                  |            modules            ||   artifacts   |
    |       conf       | number| search|dwnlded|evicted|| number|dwnlded|
    ---------------------------------------------------------------------
    |      default     |   1   |   0   |   0   |   0   ||   0   |   0   |
    ---------------------------------------------------------------------
[ivy:retrieve]
[ivy:retrieve] :: problems summary ::
[ivy:retrieve] :::: WARNINGS
[ivy:retrieve]         module not found: com.hd#ui;1.0.0
[ivy:retrieve]     ==== libraries: tried
[ivy:retrieve]       -- artifact com.hd#ui;1.0.0!ui.jar:
[ivy:retrieve]       E:\eclipse\3.3\ws\Antenna/inclib/ui-1.0.0.jar
[ivy:retrieve]     ==== hs: tried
[ivy:retrieve]       -- artifact com.hd#ui;1.0.0!ui.jar:
[ivy:retrieve]       https://cm.hd.com:8899/head-develop/dist/ui-1.0.0.jar
[ivy:retrieve]         ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve]         ::          UNRESOLVED DEPENDENCIES         ::
[ivy:retrieve]         ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve]         :: com.hd#ui;1.0.0: not found
[ivy:retrieve]         ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve]
[ivy:retrieve] :::: ERRORS
[ivy:retrieve]     HttpClientHandler:
sun.security.validator.ValidatorException: PKIX path building failed:
sun.security.provider.certpath.SunCertPathBuilderException: unable to find
valid certification path to requested target url=
https://cm.hd.com:8899/head-develop/dist/ui-1.0.0.jar
[ivy:retrieve]
[ivy:retrieve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS

BUILD FAILED
E:\eclipse\3.3\ws\Antenna\build.xml:6: The following error occurred while
executing this line:
E:\eclipse\3.3\ws\Antenna\a_build.xml:62: impossible to resolve
dependencies:
    resolve failed - see output for details

Total time: 2 seconds


Do I miss something? any help . thanks!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message