ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Burkhardt Stefan (CI/TMP)" <Stefan.Burkha...@de.bosch.com>
Subject AW: latest-compatible ConflictManager
Date Fri, 31 Oct 2008 10:39:28 GMT
Hi, 

I debugged ivy when it has to resolve the depedencies of hibernate 3.2.6.
Hibernate needs commons-collection-2.1.1 and ehcache needs commons-collection-2.1.1.

When it comes to the point where the conflict between commons-collection-2.1.1 and commons-collections-2.1
occurs
the versionMatcher is a "chainedVersionMatcher" of (version-range, sub-version, latest and
exaxt).
Where the "exact" Version matcher is used.

Do I have to make a special configuration for resolving dependencies of dependencies or
works the "latest-compatible" Conflict-Manager only on the top-level of the dependencies?

Stefan

-----Urspr√ľngliche Nachricht-----
Von: Burkhardt Stefan (CI/TMP) [mailto:Stefan.Burkhardt@de.bosch.com] 
Gesendet: Mittwoch, 29. Oktober 2008 14:46
An: ivy-user@ant.apache.org
Betreff: latest-compatible ConflictManager

Hi,

I am using the latest-compatible Conflictmanager (Ivy-Version 2.0.0 RC1)
to resolve my hibernate dependencies.
        	<dependency org="org.hibernate" name="hibernate"
rev="3.2.6.ga" conf="compile->default" transitive="true"/>

But when I try to retrieve the dependencies I get the following error.
:: problems summary ::
:::: ERRORS
        commons-collections#commons-collections;2.1 (needed by
[net.sf.ehcache#ehcache;1.2.3]) conflicts with
commons-collections#commons-collections;2.1.1 (needed by
[org.hibernate#hibernate;3.2.6.ga])

I Thougth that the latest-compatible manager evicts the
commons-collection-2.1.jar and includes the
commons-collection-2.1.1.jar. 
Am I wrong. 

Stefan

Mime
View raw message