ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Burkhardt Stefan (CI/TMP)" <Stefan.Burkha...@de.bosch.com>
Subject latest-compatible ConflictManager
Date Wed, 29 Oct 2008 13:46:18 GMT
Hi,

I am using the latest-compatible Conflictmanager (Ivy-Version 2.0.0 RC1)
to resolve my hibernate dependencies.
        	<dependency org="org.hibernate" name="hibernate"
rev="3.2.6.ga" conf="compile->default" transitive="true"/>

But when I try to retrieve the dependencies I get the following error.
:: problems summary ::
:::: ERRORS
        commons-collections#commons-collections;2.1 (needed by
[net.sf.ehcache#ehcache;1.2.3]) conflicts with
commons-collections#commons-collections;2.1.1 (needed by
[org.hibernate#hibernate;3.2.6.ga])

I Thougth that the latest-compatible manager evicts the
commons-collection-2.1.jar and includes the
commons-collection-2.1.1.jar. 
Am I wrong. 

Stefan

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message