ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Kelder" <thomaskel...@gmail.com>
Subject Re: problem with axis2 dependency
Date Fri, 01 Aug 2008 13:47:40 GMT
I'm not familiar with maven, but I tried it and the axis2-1.4.jar is
downloaded when I add this to my pom.xml:

<dependency>
    <groupId>org.apache.axis2</groupId>
    <artifactId>axis2</artifactId>
    <version>1.4</version>
</dependency>

However, when I add "axis2-parent" as artifactId, maven can't find the jar:

[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

Missing:
----------
1) org.apache.axis2:axis2-parent:jar:1.4

So I guess there's something wrong in the repository. I'll just try to solve
the problem by adding a dependency for each separate axis2-* module,
hopefully that will work.

Thanks for your help!
Thomas

On Fri, Aug 1, 2008 at 3:07 PM, Maarten Coene <maarten_coene@yahoo.com>wrote:

> Will maven download the jar?
> If that's the case, please create a JIRA issue because you've found a bug
> in Ivy.
>
> If you want to get the jar, you could try the workaround suggested here:
> https://issues.apache.org/jira/browse/IVY-633
>
> Maarten
>
>
>
> ----- Original Message ----
> From: Thomas Kelder <thomaskelder@gmail.com>
> To: ivy-user@ant.apache.org
> Sent: Friday, August 1, 2008 2:53:48 PM
> Subject: Re: problem with axis2 dependency
>
> Ok, thanks. Any ideas on how I could make it work? Can I force Ivy to try
> to
> download the jar?
>
> Thanks,
> Thomas
>
> On Fri, Aug 1, 2008 at 2:47 PM, Maarten Coene <maarten_coene@yahoo.com
> >wrote:
>
> > I think it is because the axis2 pom contains a <packaging>pom</packaging>
> > element:
> > http://repo1.maven.org/maven2/org/apache/axis2/axis2/1.4/axis2-1.4.pom
> >
> > Ivy won't try to download the jar in this case.
> >
> > Maarten
> >
> >
> >
> >
> > ----- Original Message ----
> > From: Thomas Kelder <thomaskelder@gmail.com>
> > To: ivy-user@ant.apache.org
> > Sent: Friday, August 1, 2008 2:24:19 PM
> > Subject: problem with axis2 dependency
> >
> > Hi,
> >
> > I'm new to Ivy, and I'm trying it out for my project that depends on
> axis2.
> > As a start, I created this simple Ivy file:
> >
> > <?xml version="1.0" encoding="ISO-8859-1"?>
> > <?xml-stylesheet type="text/xsl" href="
> > http://ivyrep.jayasoft.org/ivy-doc.xsl"?>
> > <ivy-module version="2.0">
> >    <info organisation="org" module="test"/>
> >    <dependencies>
> >        <dependency org="org.apache.axis2" name="axis2" rev="1.4"/>
> >        <dependency org="org.apache.axis2" name="axis2-parent" rev="1.4"/>
> >    </dependencies>
> > </ivy-module>
> >
> > And executed my ant script that runs the following ivy tasks:
> >
> >        <ivy:cleancache /> <!-- Just for testing -->
> >        <ivy:retrieve pattern="${lib.dir}/[artifact].[ext]" sync="true"/>
> >
> > When running this, Ivy only downloads the dependencies of axis2, but not
> > axis2 itself. There are no jars named axis-* in the lib directory, only
> two
> > .pom files (axis2.pom and axis2-parent.pom). Am I doing something wrong
> > here?
> >
> > Thanks!
> > Thomas
> >
> > PS. The detailed output from the ant build can be found here:
> > http://ftp2.bigcat.unimaas.nl/~thomas.kelder/out.txt<http://ftp2.bigcat.unimaas.nl/%7Ethomas.kelder/out.txt>
> <http://ftp2.bigcat.unimaas.nl/%7Ethomas.kelder/out.txt>
> >
> >
> >
> >
> >
>
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message