ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rednix <zero...@gmx.de>
Subject Re: .bundle extension in ivy retrieve... im so confused
Date Mon, 11 Aug 2008 09:48:13 GMT

Hi again,

I've done some more tests the last days. First I have to correct myself:
resolve doesn't work with "non-bundle-artifacts" either with the latest
trunk version (on our network where inet is accessible only via a corporate
proxy). I accidently missed to clear the local ivy cache for those tests. At
home I tried a random http proxy and strangly it worked fine. Then I tried
the spring repository (which was the only one that "worked" - but with a
defect ivy xml and missing dependencies - on our network) at home without a
proxy. The url to this repo is
https://springframework.svn.sourceforge.net/svnroot/springframework/repos/repo/${ivy.shared.default.ivy.pattern}
The result was the same as at work: only the requested jar and an ivy xml
without dependencies and configurations. So I have to assume that this
repo/POM is not correct and always returns a false result.
The next thing I did was comparing the relevant code of ivy in the svn on
date where the ivy-2.0.0-alpha2-incubating.jar was built and the current one
(because using the old jar there is no problem resolving standard bundles in
our network via the proxy - of course the ones with .bundle doesn't work
because the fix is just available in the latest trunk). The relevant class
is org.apache.ivy.util.url.BasicURLHandler and the method is getURLInfo().
There were minimum changes but I found the one which causes the problem: on
line 64:

((HttpURLConnection) con).setRequestMethod("HEAD");

So the new code tries to make just a head request to retrieve the URL
information. That's fine because the full body is not transfered and
therefore there is less overhead. But in my scenario this doesn't work. When
I comment this line out - everything works fine with the resolve!! I did
some research about such a problem and proxy but with no usable result.
Unfortunately I'm not a networking / TCP/IP pro. Network sniffing via tools
like Wireshark are new to me and I have no access/control over the company's
proxy infrastructure. Maybe someone else has an idea what exactly is causing
this problem.


Maarten Coene wrote:
> 
> Very strange indeed, maybe the reason why the springframework repository
> works is that you use https for it, while for the other repositories you
> use http? Do you have the same proxy for http and https? (if not, maybe
> you hit issue IVY-200 ?)
> 
> But that doesn't explain why it works for the not "bundle-artifacts".
> 
> Maarten
> 
> 

-- 
View this message in context: http://www.nabble.com/.bundle-extension-in-ivy-retrieve...-im-so-confused-tp18562574p18922701.html
Sent from the ivy-user mailing list archive at Nabble.com.


Mime
View raw message