ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Christie" <Jim.Chris...@Tideworks.com>
Subject RE: Dynamic revisions question
Date Mon, 21 Jul 2008 00:27:57 GMT
Maarten-

Thanks for the reply.  I tried adding an ivy pattern to the resolver,
but I'm still getting the same error.  After adding the ivy pattern I
tried specifying the dependency using both the + wildcard as well as
with a version-range expression.  The outcome was the same in both
cases.  I noticed there was a JIRA issue about this, but it was a while
back and it was my impression that this was working in 2.0.0 beta.  I'm
sure it's something on my end, but I can't seem to figure out what it
is.  Maybe I'll see if the Artifactory repository can be made available
as a filesystem share (only available via http right now) and try with a
filesystem resolver.

Jim




-----Original Message-----
From: Maarten Coene [mailto:maarten_coene@yahoo.com] 
Sent: Saturday, July 19, 2008 5:34 AM
To: ivy-user@ant.apache.org
Subject: Re: Dynamic revisions question

Could you try adding an ivy-pattern to your artifactory resolver?
It could be that Ivy is having troubles resolving dynamic revisions if
there is no ivy-pattern defined.

Maarten



----- Original Message ----
From: Jim Christie <Jim.Christie@Tideworks.com>
To: ivy-user@ant.apache.org
Sent: Friday, July 18, 2008 11:10:22 PM
Subject: Dynamic revisions  question

I'm having some difficulty getting dynamic revisions working in
v2.0.0-beta2.  Everything works fine as long as I specify a complete
revision number, for example: <dependency org="commons-logging"
name="commons-logging" rev="1.0.4" transitive="false"/>.  However, if I
attempt to specify a dynamic revision, it won't work.  

For example, this:
  <dependency org="commons-logging" name="commons-logging" rev="1.0.+"
transitive="false"/>

Results in this message:
[ivy:retrieve] :: problems summary ::
[ivy:retrieve] :::: WARNINGS
[ivy:retrieve]          module not found:
commons-logging#commons-logging;1.0.+
[ivy:retrieve]  ==== artifactory: tried
[ivy:retrieve]    -- artifact
commons-logging#commons-logging;1.0.+!commons-logging.jar:
[ivy:retrieve]
http://reposvr:8081/artifactory/repo/commons-logging/commons-logging/1.0
.+/commons-logging-1.0.+.jar
[ivy:retrieve]
http://reposvr:8081/artifactory/repo/commons-logging/commons-logging/[re
vision]/commons-logging-[revision].jar
[ivy:retrieve]          ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve]          ::          UNRESOLVED DEPENDENCIES         ::
[ivy:retrieve]          ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve]          :: commons-logging#commons-logging;1.0.+: not
found
[ivy:retrieve]          ::::::::::::::::::::::::::::::::::::::::::::::

My ivysettings.xml looks like this (we specify an enterprise repository
running on Artifactory and ibiblio as a fallback).

<ivysettings>
  <settings defaultResolver="chained"/>
    <resolvers>
      <chain name="chained">
        <url name="artifactory">
          <artifact 
    
pattern="http://reposvr:8081/artifactory/repo/[organisation]/[module]/[r
evision]/[artifact]-[revision].[ext]" />
        </url>
        <ibiblio name="ibiblio" />
      </chain>
  </resolvers>
</ivysettings>

I have tried several work-arounds including using version range syntax,
'latest.integration' and replacing the url resolver with an ibiblio
resolver with its root and pattern attributes set to the specifics for
our enterprise repository, but to no avail.  Again, if I specify a
complete version number, it works fine, so I know that Ivy is set up
correctly.  Any advice on what I'm doing wrong would be greatly
appreciated.  Thanks in advance.

Jim


      

Mime
View raw message