ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff DeCew <jde...@blue.aero>
Subject trouble using ivy-svn in eclipse
Date Tue, 08 Jul 2008 16:38:41 GMT
I am trying to use IVY with Ivy-svn and IvyDE, but the two don't seem to work together.
I have configured everything to work when building from the command line, and building works
just as well inside eclipse, but when I try to add IvyDE Managed Dependencies to the project,
it gives me this error about the IvySettings file being broken.

> Problem occurred while using file:/C:/ivy/settings/ivysettings.xml to configure Ivy.
> Please set your ivy settings url properly in the preference or in the project properties
to be able to use IvyDE.
> Exception message: failed to load settings from file:/C:/ivy/settings/ivysettings.xml:
impossible to define new type: class not found: fm.last.ivy.plugins.svnresolver.SvnResolver
in [] nor Ivy classloader

Because everything works fine when I'm using Ivy in Ant, I get the impression that my problem
is in using Ivy with IvyDE and Eclipse.  Do I need to install the ivysvnresolver for eclipse
in some way?  How would I do this?

Thanks,
--Jeff

Mime
View raw message