ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée <nicolas.lale...@hibnet.org>
Subject Re: ivyde: classpath container disappears when all dependencies removed
Date Mon, 09 Jun 2008 14:25:38 GMT
Le lundi 9 juin 2008, Clements Mark a écrit :
> > -----Original Message-----
> > From: Clements Mark [mailto:clements@OFAC.CH]
> > Sent: Monday, May 26, 2008 12:37 PM
> > I have a project that contains the following dependencies in its
>
> ivy.xml
>
> > <dependencies>
> >     <dependency org="easymock" name="easymock" rev="2.3" />
> >     <dependency org="apache" name="commons-lang" rev="latest.release"
>
> />
>
> >     <dependency org="org.codehaus" name="groovy"
>
> rev="latest.release"/>
>
> > </dependencies>
> >
> >
> > I can resolve and retrieve artifacts without any problem. If I remove
> > all the dependencies and run a resolve, the ivy.xml container
>
> disappears
>
> > from the project, meaning that it's a bit fiddly to run resolve again
>
> Hi - if nobody objects, I'd like to post this as a (minor) bug in IvyDE.
> Thanks - Mark

Sorry I didn't answer sooner to your mail.
Actually this is a know issue: IVYDE-82. And it seems to be a feature of 
Eclipse... we have to found a good workaround, any ideas will be appreciated.

Nicolas

>
> > when I add the dependencies back in. A workaround is to do
> >
> > build path -> configure build path
> > 	-> remove ivy.xml
> > 	-> add library
> > 	-> ivyde managed dependencies
> >
> > which forces a resolve, but this feels a little clumsy. May I post a
>
> bug
>
> > for this issue? Note that I'm running with the latest build from
>
> hibnet
>
> > - thanks Nicolas and whoever else was involved for fixing the last
>
> issue
>
> > that I posted (IVYDE-93).
> >
> > Thanks,
> >
> > Mark



Mime
View raw message