ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim White <...@pagesmiths.com>
Subject Re: Issue downloading dependency
Date Fri, 02 May 2008 18:48:26 GMT
It's an OSGI bundle and Ivy currently thinks it should therefore end 
with '.bundle' rather than '.jar'.  The workaround is to use an artifact 
specification to override the extension.

http://marc.info/?l=ivy-user&m=120842825928326&w=2
http://marc.info/?l=ivy-user&m=120842941430186&w=2

Add this within the <dependency> element:

<artifact name="spring-security-core" ext="jar"/>

Jim

Michael Laccetti wrote:

> I'm trying to include Spring Security (formerly Acegi) 2.0.1.  It has been
> published to a Maven repository, so I added the following to my ivy.xml:
> 
> <dependency org="org.springframework.security" name="spring-security-core"
> rev="2.0.1" />
> <dependency org="org.springframework.security"
> name="spring-security-adapters" rev="2.0.1" />
> 
> When I run ant, I get the following error:
> [ivy:resolve]   ==== ibiblio: tried
> [ivy:resolve]    
> http://repo1.maven.org/maven2/org/springframework/security/spring-security-core/2.0.1/spring-security-core-2.0.1.bundle
> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve]           ::              FAILED DOWNLOADS            ::
> [ivy:resolve]           :: ^ see resolution messages for details  ^ ::
> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve]           ::
> org.springframework.security#spring-security-core;2.0.1!spring-security-core.bundle
> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
> 
> My question is:  where is this ".bundle" stuff coming from?
> 
> Mike
> 
> -----
> --
> Michael Laccetti                                 (416)558-9718
> S2G Limited                                       http://www.s2g.ca/


Mime
View raw message