ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Trevin Beattie <tbeat...@boingo.com>
Subject Re: Problem: failed to create task or type antlib:org.apache.ivy.ant:retrieve
Date Thu, 17 Apr 2008 19:02:35 GMT
More details: I downloaded a fresh copy of the source tarballs of both
ant-1.6.2 and ant-1.6.5 from archive.apache.org, built them (without any
vendor patches), and ran the full command line for each, *without*
explicitly adding ivy on the classpath.  With ant-1.6.2, the build
succeeded.  With ant-1.6.5, the build failed.  So it looks like ivy is
incompatible with newer versions of ant.  (1.6.5 is 3 years old, BTW)

-- Trevin

On Thu, 2008-04-17 at 11:33 -0700, Trevin Beattie wrote:
> I'm running on Fedora Core 6, which comes with ant-1.6.5-2jpp.2.  I've
> downloaded apache-ivy-2.0.0-beta2 and copied ivy-2.0.0-beta2.jar to
> ~/.ant/lib/.  When I attempt to build the hello-ivy test, I get the
> following failure message:
> 
> [tbeattie@ernie hello-ivy]$ ant
> Buildfile: build.xml
> 
> resolve:
> 
> BUILD FAILED
> /home/tbeattie/src/apache-ivy-2.0.0-beta2/src/example/hello-ivy/build.xml:38: Problem:
failed to create task or type antlib:org.apache.ivy.ant:retrieve
> Cause: The name is undefined.
> Action: Check the spelling.
> Action: Check that any custom tasks/types have been declared.
> Action: Check that any <presetdef>/<macrodef> declarations have taken place.
> 
> This appears to be an antlib declaration. 
> Action: Check that the implementing library exists in one of:
>         -/usr/share/ant/lib
>         -/home/tbeattie/.ant/lib
>         -a directory added on the command line with the -lib argument
> 
> 
> Total time: 0 seconds
> [tbeattie@ernie hello-ivy]$ ls /usr/share/ant/lib /home/tbeattie/.ant/lib
> /home/tbeattie/.ant/lib:
> ivy-2.0.0-beta2.jar
> 
> /usr/share/ant/lib:
> ivy-2.0.0-beta2.jar
> 
> I've also tried copying ivy-2.0.0-beta2.jar to /usr/share/ant/lib/, and
> upgraded ant to the version 1.7.0-1jpp.4.  It still gives me the same
> error.
> 
> A coworker gets the same error on Red Hat Enterprise Linux 5 with
> ant-1.6.5 installed, but if he downgrades to ant-1.6.2 (packaged by
> JPackage Project, not by Red Hat) then it works.
> 
> Any ideas what could be wrong -- is it incompatible with ant 1.6.5+ or
> is the Red Hat distribution of ant missing some vital build step?
> 
> One more thing that may help: if I run `ant --execdebug', add
> "/home/tbeattie/.ant/lib/ivy-2.0.0-beta2.jar" to the end of the (very
> long) generated classpath, and enter the resulting command line, the
> build will succeed:

[snip]

> -- Trevin Beattie



Mime
View raw message