ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier Hanin" <xavier.ha...@gmail.com>
Subject Re: using Ivy.resolve programmatically
Date Mon, 17 Mar 2008 16:36:57 GMT
On Wed, Mar 12, 2008 at 11:40 PM, Antoine Levy-Lambert <antoine@gmx.de> wrote:
> Hi,
>
>  I must be missing something.
>
>  We are still on ivy-2.0.0-alpha2 (sorry that we did not upgrade yet).
>
>  I try to reproduce in a separate java class (a CruiseControl custom plugin) what the
Ant task ivy:resolve does.
>
>  I see some output looking like the normal output of ivy resolve. But afterwards, I see
a message indicating a number of modules to sort, and messages containing this string Non
matching revision detected when sorting.
>
>  In the end, there are a lot of dependencies which are missing from my ResolveReport
instance. Am I doing anything wrong ? Is there a magic API call to do to get the complete
list of dependencies ?
There's nothing magic... If you want to understand precisely how Ivy
itself interpret the ResolveReport I suggest having a look at the
report outputter (LogReportOutputter and XmlReportOutputter). If you
post an example of what you're doing we may help trying to see what
can be wrong.

Xavier
>
>  Regards,
>
>  Antoine
>
>      [java]     |       emma       |   1   |   0   |   0   |   0   ||   2   |   0   |
>
>      [java]     |      aspectj     |   2   |   0   |   0   |   0   ||   1   |   0   |
>
>      [java]     |   binaryaspect   |   1   |   0   |   0   |   0   ||   1   |   0   |
>
>      [java]     |     platform     |   1   |   0   |   0   |   0   ||   2   |   0   |
>
>      [java]     |      default     |   0   |   0   |   0   |   0   ||   0   |   0   |
>
>      [java]     ---------------------------------------------------------------------
>
>      [java] Nbr of module to sort : 35
>
>      [java] Sort dependencies of : [ acme | ctaspects | 5.1 | CTASPECTS_5.1.0.579 ] /
Number of dependencies = 2
>
>      [java] Non matching revision detected when sorting.  [ acme | ctWebClient ] depends
on [ apache | oro | 5.1 | 2.0.8 ], doesn't match [ apache | oro | 5.1 | 2.0.6 ]
>
>  ...
>
>
>



-- 
Xavier Hanin - Independent Java Consultant
http://xhab.blogspot.com/
http://ant.apache.org/ivy/
http://www.xoocode.org/

Mime
View raw message