ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hans Dockter <m...@dockter.biz>
Subject Re: New errors messages in log since update to Ivy-beta2
Date Wed, 05 Mar 2008 15:59:04 GMT

On Mar 5, 2008, at 4:46 PM, Xavier Hanin wrote:

> On Wed, Mar 5, 2008 at 4:42 PM, Hans Dockter <mail@dockter.biz> wrote:
>
>>
>> On Mar 5, 2008, at 4:34 PM, Xavier Hanin wrote:
>>
>>> On Wed, Mar 5, 2008 at 3:51 PM, Hans Dockter <mail@dockter.biz>  
>>> wrote:
>>>
>>>>
>>>>>
>>>>> It seems you don't use the same ivy.jar in both cases. Is
>>>>> ivy-2.0.0.beta2_20080103202250.jar a home made build, or a copy  
>>>>> from
>>>>> ivy-2.0.0-beta2.jar?
>>>>>
>>>>
>>>> You are right. I forgot to update. Now the situation is pretty much
>>>> as described in my first mail.
>>>>
>>>> When I now start Gradle from IntelliJ or from the command line I  
>>>> get
>>>> the error messages. I don't get the error messages with my ant  
>>>> build.
>>>> My ant-build is also using ivy-beta2 (I've made sure that there  
>>>> is no
>>>> old ivy lib in the ant-home lib folder, as I install Ivy via my
>>>> build.xml).
>>>
>>> I suspect the difference is the xml parser used. Run "ant -
>>> diagnostics" and
>>> you will see a section telling which Xml parser is used. Here is  
>>> mine:
>>> -------------------------------------------
>>>  XML Parser information
>>> -------------------------------------------
>>> XML Parser : org.apache.xerces.jaxp.SAXParserImpl
>>> XML Parser Location: /usr/share/java/xercesImpl.jar
>>> Namespace-aware parser : org.apache.xerces.jaxp.SAXParserImpl
>>> $JAXPSAXParser
>>> Namespace-aware parser Location: /usr/share/java/xercesImpl.jar
>>>
>>> If your ant install use xerces as mine, try adding to your
>>> classpath in
>>> gradle, to see what happens.
>>>
>>> Xavier
>>
>> Spot on, Xavier.
>>
>> ant -diagnostics says:
>>
>> -------------------------------------------
>>  XML Parser information
>> -------------------------------------------
>> XML Parser : org.apache.xerces.jaxp.SAXParserImpl
>> XML Parser Location: /Users/hans/java/apache-ant/lib/xercesImpl.jar
>> Namespace-aware parser : org.apache.xerces.jaxp.SAXParserImpl
>> $JAXPSAXParser
>> Namespace-aware parser Location: /Users/hans/java/apache-ant/lib/
>> xercesImpl.jar
>>
>> If I add /Users/hans/java/apache-ant/lib/xercesImpl.jar to the Gradle
>> classpath, there are no error messages.
>
> OK, so at least we have a workaround for beta2, so it can wait for  
> next
> release to have the fix. BTW, I'd be interested to confirm if using a
> current trunk build actually avoid the error messages in your case  
> (without
> xerces). Could you give it a try?

With ivy trunk I don't get the error messages (I have removed xerces  
from my classpath).

- Hans

Mime
View raw message