ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Castrianni <Shawn.Castria...@halliburton.com>
Subject cache settings
Date Sun, 24 Feb 2008 18:08:37 GMT
The cache documentation says not to use the same resolution cache at the same time, "should
never be used by multiple processes at the same time"

On an automated build server, I can see that this could easily happen.  Therefore, I am thinking
I need to specify the defaultCache directory on the settings tag to use different cache dirs
for each build.  The best way to do that is to the use build number in the defaultCache value.
 However, in order to get the buildnumber, you have to call buildnumber which requires the
settings to be loaded and a cache to be used.

I am stuck with a chicken and egg problem.  How do I differentiate my caches so that the resolution
cache isn't used more by multiple processes at the same time?

---
Shawn Castrianni

----------------------------------------------------------------------
This e-mail, including any attached files, may contain confidential and privileged information
for the sole use of the intended recipient.  Any review, use, distribution, or disclosure
by others is strictly prohibited.  If you are not the intended recipient (or authorized to
receive information for the intended recipient), please contact the sender by reply e-mail
and delete all copies of this message.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message