ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier Hanin" <>
Subject Re: specify versions separate from dependencies
Date Wed, 27 Feb 2008 17:56:44 GMT
On Wed, Feb 27, 2008 at 6:47 PM, Niklas Matthies <>

> On Wed 2008-02-27 at 17:04h, Xavier Hanin wrote on ivy-user:
> > On Wed, Feb 27, 2008 at 4:59 PM, Niklas Matthies wrote:
> :
> > > How would this be different from a regular dependency with a "force"
> > > attribute?
> >
> > It's different only in concept: I don't like having to add a dependency
> > declaration when your module don't actually depend on something. Later
> you
> > can wonder why you have this dependency. That's why we have the
> conflicts
> > section in Ivy files. So I think this kind of dependency version
> overloading
> > deserves a new feature.
> Okay, then how about adding an "override-only" attribute to dependency
> declarations? Or as a new value of the "transitive" attribute (i.e.
> transitive="override-only"). My feeling is that the feature has too
> much in common with real dependencies. (It actually *is* a dependency
> in the sense of demanding a particuar revision.) Every new feature
> added to "dependency" that is also applicable to the revision override
> features (like branches and extra attributes) would have to be carried
> over, and documented separately. Or else the feature set diverges over
> time.

Mm, we currently use dependencies/dependency only for direct dependencies.
And this is not a direct dependency. So I'd really prefer to keep it
separated, as the conflicts section.

> Also the name "dependencyManagement" is really, really bad. :)
> *Everything* in an ivy file is about dependendency management.
> At least make it "dependency-override" or something like that.
> [Note: I've never used Maven. Adopting non-descriptive names from
> Maven just to make Maven users feel more comfortable with a feature
> which (probably) does almost-but-not-exactly the same thing as in
> Maven feels like a really bad trade-off to me. ;)]

I agree, it's a bad idea. dependency-override sounds like a much better
name, if we only put dependency overriding here. Someone suggested to merge
the conflicts/manager with this, since both actually tweak the way
transitive dependencies are handled. Maybe we could find a better and more
explicit syntax which could address both concerns? Suggestions, anyone?


> -- Niklas Matthies

Xavier Hanin - Independent Java Consultant

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message