ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier Hanin" <xavier.ha...@gmail.com>
Subject Re: install task bug?
Date Fri, 08 Feb 2008 08:51:37 GMT
On Feb 8, 2008 7:10 AM, Shawn Castrianni <Shawn.Castrianni@halliburton.com>
wrote:

> I am trying to use the install task for the first time.  I have noticed
> two things:
>
> 1. the install task does not have a branch attribute to help specify which
> module to install

This is indeed a missing feature. Please open an issue about that.

>
> 2. the validate attribute doesn't seem to work.  I get an invalid xml
> error when it parsed the ivy.xml since it has extra attributes.  The docs
> say that the validate will default to whatever is in my settings.
>  Apparently it doesn't since it is set to false.  If I specify
> validate="false" on the install task invocation, it still doesn't work.
>  Still getting parse error.

This is a bug, I've checked the code, InstallEngine actually doesn't use the
validate parameter :-( Very easy to fix though, please open an issue.

Xavier

>
>
> ---
> Shawn Castrianni
> Landmark
> Halliburton Drilling, Evaluation and Digital Solutions
> Building 2
> 2101 City West Blvd.
> Houston, TX  77042
> Work:  713-839-3086
> Cell:  832-654-0888
> Fax:  713-839-2758
>
> ----------------------------------------------------------------------
> This e-mail, including any attached files, may contain confidential and
> privileged information for the sole use of the intended recipient.  Any
> review, use, distribution, or disclosure by others is strictly prohibited.
>  If you are not the intended recipient (or authorized to receive information
> for the intended recipient), please contact the sender by reply e-mail and
> delete all copies of this message.




-- 
Xavier Hanin - Independent Java Consultant
http://xhab.blogspot.com/
http://ant.apache.org/ivy/
http://www.xoocode.org/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message