ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wyz <wangyiz...@gmail.com>
Subject SSH repository seems does not work with Ubuntu/Suse Enterprise
Date Tue, 19 Feb 2008 01:38:11 GMT

Hi, I was trying to set up a ivy environment for my company. I was using
Ubuntu 7.10 for client and Suse Server for server. I will get a NPE when
trying to authenticate. I go in to the code found out the cause of NPE is
Passphrase is not provided. So I think a better message should be provided.

The error message is not that important though. The problem is I cannot
authenticate with my Account. I searched over the Internet and the only hint
I found is Ubuntu/Suse Enterprise does not support password authentication,
and interactive authentication (if I remember correct) should be used
instead. 

There is a test case I created for testing authentication. The logic is what
Ivy used. It always fails in my environment. And I did not test it in
windows.

public class testSSH {
	public static void main(String[] args) {
		SshCache cache = SshCache.getInstance();
	
		MD5 md5 = new MD5();
		
		if (keyFile.exists()) {
			System.out.println("File exists");
		}
		try {
			cache.getSession(host-ip, 22, username, password, null, null, null);
		} catch (IOException e) {
			e.printStackTrace();
		}	
	}
}

Btw, I found documentation for setting up repositories is a bit lacking.
-- 
View this message in context: http://www.nabble.com/SSH-repository-seems-does-not-work-with-Ubuntu-Suse-Enterprise-tp15550830p15550830.html
Sent from the ivy-user mailing list archive at Nabble.com.


Mime
View raw message