ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume <guilla...@eruva.net>
Subject Re: Using IvyDE
Date Wed, 16 Jan 2008 09:23:54 GMT
Xavier Hanin a écrit :
> On Jan 15, 2008 10:35 AM, Guillaume <guillaume@eruva.net> wrote:
>
>   
>> Hello,
>>
>> I want to integrate Ivy in an enterprise continous integration and build
>> system. The whole picture
>> is to have a central repository for the libraries (at the moment i'm
>> mocking this repository with
>> artifactory). Developpers are using Eclipse (various versions ranging from
>> 3.0 to 3.3).
>>
>> Unfortunately i have a bit of trouble when it comes to IvyDE's integration
>> and Eclipse 3.3. I
>> found some interesting discussions in the archives but it's still not
>> working. Selecting my
>> project and then trying to add an IvyDE Managed Dependencies library
>> fails. No error and almost no
>> result except an empty "ivy.xml[*]" addition hidden in the buildpath (not
>> shown in the package
>> explorer but appears in properties-->build path).
>>
>> I know IvyDE would do the job i'm looking for. I've seen Xavier's demo at
>> Javapolis (thank you
>> Xavier for your nice demo).
>>
>> Thanks for any help, regards,
>>     
>
> First, I suggest making sure your ivy settings work from Ant or from the
> command line: it's much easier to debug. Then if it works from Ant you may
> have a problem of eclipse configuration. Are you sure your ivy settings URL
> is correct? When you say you see no log at all, have you checked the eclipse
> error log? And the Ivy Console view?
>
> Xavier
>
>   
Following your advice, I edited the build.xml of the hello-ivy example 
to add a reference to my settings file. Everything worked. Back to 
eclipse, I've imported the hello project. And i was able to add the 
ivyde managed dependencies library. As far my test project was 
concerned, it was still failing silently (nothing in eclipse error log 
view). I've recreated a copy of it from scratch and this copy worked.
Trying to figure out why the original test project was still failing, i 
tried a few tricks (moving settings file around, entering a wrong 
ivyconf url and back to the proper to force a refresh, changed jdk). It 
appeared that suddently, the ivy managed dependencies library showed up. 
Unfortunately I'm not able to tell what was wrong. I tried to reproduce 
the behaviour i had without success.

Thanks for your help,
Guillaume


Mime
View raw message