ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume" <guilla...@eruva.net>
Subject [No Subject]
Date Tue, 15 Jan 2008 09:15:35 GMT


Hello,

I want to integrate Ivy in an enterprise continous
integration and build
system. The whole picture is to have a central
repository for the
libraries (at the moment i'm mocking this
repository with artifactory).
Developpers are using Eclipse (various
versions ranging from 3.0 to
3.3).

Unfortunately i have a
bit of trouble when it comes to IvyDE's
integration and Eclipse 3.3.
I found some interesting discussions in the
archives but it still not
working. Selecting my project and then trying
to add an IvyDE Managed
Dependencies library fails. No error and almost
no result except an
empty "ivy.xml[*]" addition hidden in the buildpath
(not
shown in the package explorer but appears in properties-->build
path). 

I know IvyDE would do the job i'm looking for. I've
seen Xavier's demo
at Javapolis (thank you Xavier for your nice
demo).

Thanks for any help, regards,
Guillaume

PS: Some details about my attempts.

Ivy:
apache-ivy-2.0.0-beta1
installed with the build.xml file provided
at
http://www.mail-archive.com/ivy-user@incubator.apache.org/msg02151.html

IvyDE and Eclipse 3.3:
using the jar from xoocode named
org.apache.ivyde.eclipse_1.3.0.20071209120000.jar

Here is my
ivy.xml:
<?xml version="1.0"
encoding="ISO-8859-1"?>
<ivy-module
version="1.0">
   <info
organisation="TestOrg" module="TestModule"
status="integration"
/>
   <configurations
defaultconfmapping="test">
      <conf
name="test" />
   </configurations>
  
<dependencies>
      <dependency org="junit"
name="junit" revision="3.8.1"
conf="test"/>
   </dependencies>
</ivy-module>

Here is my ivy-settings.xml (reference in
eclipse
windows-->preference-->ivy-->IvyConf Url):
I'm
using artifactory as a cache to repo1.maven.org/maven2
<?xml
version="1.0" encoding="ISO-8859-1"?>
<ivysettings>
   <settings
defaultResolver="artifactory" checkUpToDate="false"
/>
   <resolvers>
      <url
name="artifactory">
         <ivy
pattern="http://localhost:8081/artifactory/repo/[module]/[revision]/ivy-
[revision].xml" />
         <artifact
pattern="http://localhost:8081/artifactory/repo/[organisation]/[module]/
[revision]/[artifact]-[revision].[ext]" />
     
</url>
   </resolvers>
</ivysettings>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message