ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Crystal, Mayer" <mayer.crys...@gs.com>
Subject RE: Question about revision conflicts during resolve/retrieve
Date Thu, 06 Dec 2007 15:53:18 GMT
This wouldn't by chance be backward compatible with 1.4, would it? :) 

-----Original Message-----
From: Xavier Hanin [mailto:Xavier.Hanin@sas.com] 
Sent: Thursday, December 06, 2007 10:51 AM
To: ivy-user@incubator.apache.org
Subject: RE: Question about revision conflicts during resolve/retrieve

> -----Original Message-----
> From: Crystal, Mayer [mailto:mayer.crystal@gs.com]
> Sent: Thursday, December 06, 2007 10:47 AM
> To: ivy-user@incubator.apache.org
> Cc: Etkine, Dmitri
> Subject: Question about revision conflicts during resolve/retrieve
>
> We are using Ivy 1.4.1 and had a question about conflict resolution 
> between 2 modules.  Let's say we have a setup like:
>
> A depends on B version 1.4 and C version 1.5 B depends on C version 
> 1.+ Version C in the repository is 1.7
>
>
> Is there a way to tell ivy that when it is resolving, if it comes 
> across a firm requirement (1.5 for C for module A) which doesn't 
> conflict with other requirements (the 1.+ for C for module B) to 
> always choose the strict requirement?
This is exactly what the latest-compatible-conflict-manager introduced
recently do:
https://issues.apache.org/jira/browse/IVY-648

This is available in trunk and will be too in 2.0.0 beta 1 which is just
around the corner.

Xavier

>
>
>
> Thanks,
> Mayer

Mime
View raw message