ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Adams <Jim.Ad...@sas.com>
Subject RE: Question about revision conflicts during resolve/retrieve
Date Thu, 06 Dec 2007 15:49:37 GMT
We call this the "Polygon of Death". There will be a conflict manager in the beta called LatestCompatibleConflictManager
which will handle this case.

Jim Adams

> -----Original Message-----
> From: Crystal, Mayer [mailto:mayer.crystal@gs.com]
> Sent: Thursday, December 06, 2007 10:47 AM
> To: ivy-user@incubator.apache.org
> Cc: Etkine, Dmitri
> Subject: Question about revision conflicts during resolve/retrieve
>
> We are using Ivy 1.4.1 and had a question about conflict resolution
> between 2 modules.  Let's say we have a setup like:
>
> A depends on B version 1.4 and C version 1.5
> B depends on C version 1.+
> Version C in the repository is 1.7
>
>
> Is there a way to tell ivy that when it is resolving, if it comes across
> a firm requirement (1.5 for C for module A) which doesn't conflict with
> other requirements (the 1.+ for C for module B) to always choose the
> strict requirement?
>
>
>
> Thanks,
> Mayer


Mime
View raw message