ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles Scokart" <gscok...@gmail.com>
Subject RE: Problem with Tutorial
Date Wed, 05 Dec 2007 13:37:59 GMT
Did you use the tutorials distributed with 2.0-alpha-2 or the one currently on the trunk in
svn?

The tutorials have been deeply reviewed since alpha-2.  We will release beta-1 soon with the
new tutorials (soon =
probably this week).

Gilles

> -----Original Message-----
> From: Steve Appling [mailto:sajakarta@appling.org]
> Sent: mercredi 5 d├ęcembre 2007 14:32
> To: ivy-user@incubator.apache.org
> Subject: Problem with Tutorial
> 
> I'm just starting to investigate Ivy, but am having problems getting the
> tutorial at http://ant.apache.org/ivy/history/trunk/tutorial.html to
> work.  Any help would be appreciated.  I'm not behind any proxy.  Does
> this tutorial's build file work for other people now?
> 
> I get the following result when running ant :
> ... removed initial part
> 
> go:
>      [echo] using ivy to resolve commons-lang 2.1...
> [ivy:cachepath] :: Ivy 2.0.0-alpha2-incubating - 20070712142751 ::
> http://incubator.apache.org/ivy/ ::
> [ivy:cachepath] No ivy:settings found for the default reference
> 'ivy.instance'. A default instance will be used
> [ivy:cachepath] no settings file found, using default...
> [ivy:cachepath] :: loading settings :: url =
> jar:file:/C:/temp/ivy-test/ivy/ivy.jar!/org/apache/ivy/core/settings/ivysettings.xml
> [ivy:cachepath] :: resolving dependencies :: [ commons-lang |
> commons-lang-caller | working ]
> [ivy:cachepath]         confs: [default, master, compile, provided,
> runtime, test, system]
> [ivy:cachepath]         found [ commons-lang | commons-lang | 2.1 ] in
> public
> [ivy:cachepath] :: resolution report ::
> 
> ---------------------------------------------------------------------
>         |                  |            modules            ||
> artifacts   |
>         |       conf       | number| search|dwnlded|evicted||
> number|dwnlded|
> 
> ---------------------------------------------------------------------
>         |      default     |   1   |   0   |   0   |   0   ||   0   |
> 0   |
>         |      master      |   1   |   0   |   0   |   0   ||   0   |
> 0   |
>         |      compile     |   1   |   0   |   0   |   0   ||   0   |
> 0   |
>         |     provided     |   1   |   0   |   0   |   0   ||   0   |
> 0   |
>         |      runtime     |   1   |   0   |   0   |   0   ||   0   |
> 0   |
>         |       test       |   1   |   0   |   0   |   0   ||   0   |
> 0   |
>         |      system      |   1   |   0   |   0   |   0   ||   0   |
> 0   |
> 
> ---------------------------------------------------------------------
> [ivy:cachepath]
> [ivy:cachepath] :: problems summary ::
> [ivy:cachepath] :::: WARNINGS
> [ivy:cachepath]
> ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:cachepath]                 ::          UNRESOLVED
> DEPENDENCIES         ::
> [ivy:cachepath]
> ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:cachepath]                 :: [ commons-lang | commons-lang | 2.1
> ]: configuration not public in [ commons-lang | commons-lang | 2.1 ]:
> test. It was required from [ commons-lang | commons-lang-caller |
> working ] test
> [ivy:cachepath]
> ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:cachepath]
> [ivy:cachepath]
> [ivy:cachepath] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
> 
> BUILD FAILED
> C:\temp\ivy-test\build.xml:85: impossible to resolve dependencies:
> resolve failed - see output for details



Mime
View raw message