ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier Hanin" <xavier.ha...@gmail.com>
Subject Re: ivy not working out of the box
Date Fri, 16 Nov 2007 07:48:29 GMT
On Nov 15, 2007 6:58 PM, jonathan doklovic <jdoklovic@ibsys.com> wrote:

> Not sure why, but it didn't like the packaged install of ant in openSuse
> 10.3
>
> I removed ant using the package manager, then installed it in my home
> folder from the ant-1.7.0.tar.gz file, and now everything works.
>
> weird.


Really weird. Maybe you could open an issue for later reference. I'm not
sure we will be able to investigate ourself on the issue, but if someone
else has the problem it's good to have an issue in JIRA reporting the
problem and the workaround.

Xavier


>
>
> - Jonathan
>
>
> On Thu, 2007-11-15 at 17:25 +0100, Xavier Hanin wrote:
> > It's weird. Silly question: have you checked if ivy jar is ok: try to
> > open it with a zip utility, or use javap to check some classes...
> >
> > Xavier
> >
> > On Nov 15, 2007 4:00 PM, jonathan doklovic < jdoklovic@ibsys.com>
> > wrote:
> >         ant -version:
> >         Apache Ant version 1.7.0 compiled on September 22 2007
> >
> >         ant -diagnostics:
> >         -------------------------------------------
> >          ANT_HOME/lib jar listing
> >         -------------------------------------------
> >         ant.home: /usr/share/ant
> >         ant-antlr-1.7.0.jar (5749 bytes)
> >         ant-jdepend-1.7.0.jar (8125 bytes)
> >         ant-apache-resolver.jar (4074 bytes)
> >         ant-apache-bsf.jar (3957 bytes)
> >         ant-1.7.0.jar (1286579 bytes)
> >         ant-launcher-1.7.0.jar (11718 bytes)
> >         ant-trax-1.7.0.jar (6884 bytes)
> >         ant-junit.jar (92583 bytes)
> >         ant-apache-resolver-1.7.0.jar (4074 bytes)
> >         ant-jmf-1.7.0.jar (6596 bytes)
> >         ant-nodeps.jar (428573 bytes)
> >         ant-jdepend.jar (8125 bytes)
> >         ant-apache-log4j-1.7.0.jar (3059 bytes)
> >         ant-junit-1.7.0.jar (92583 bytes)
> >         ant-commons-logging.jar (3913 bytes)
> >         ant-commons-logging-1.7.0.jar (3913 bytes)
> >         ant-apache-oro.jar (39542 bytes)
> >         ant-apache-oro-1.7.0.jar (39542 bytes)
> >         ant-nodeps-1.7.0.jar (428573 bytes)
> >         ant-apache-log4j.jar (3059 bytes)
> >         ant-apache-regexp-1.7.0.jar (3730 bytes)
> >         ant-javamail-1.7.0.jar (7001 bytes)
> >         ant-swing-1.7.0.jar (6698 bytes)
> >         ant-apache-regexp.jar (3730 bytes)
> >         ivy-2.0.0-alpha2-incubating.jar (687938 bytes)
> >         ant.jar (1286579 bytes)
> >         ant-jmf.jar (6596 bytes)
> >         ant-javamail.jar (7001 bytes)
> >         ant-swing.jar (6698 bytes)
> >         ant-apache-bcel.jar (8596 bytes)
> >         ant-launcher.jar (11718 bytes)
> >         ant-apache-bcel-1.7.0.jar (8596 bytes)
> >         ant-apache-bsf-1.7.0.jar (3957 bytes)
> >         ant-trax.jar (6884 bytes)
> >         ant-antlr.jar (5749 bytes)
> >
> >
> >         ivy jar is listed in $ANT_HOME/lib ... Driving me nuts!
> >
> >         - Jonathan
> >
> >
> >
> >
> >         On Thu, 2007-11-15 at 15:54 +0100, Gilles Scokart wrote:
> >         > You can check what is really in the classpath by running ant
> >         -diagnostics (in java.classpath).
> >         >
> >         > By the way, which version of ant are you using?
> >         >
> >         > Gilles
> >         >
> >         > > -----Original Message-----
> >         > > From: jonathan doklovic [mailto:jdoklovic@ibsys.com]
> >         > > Sent: jeudi 15 novembre 2007 15:24
> >         > > To: ivy-user@incubator.apache.org
> >         > > Subject: ivy not working out of the box
> >         > >
> >         > > Hi,
> >         > >
> >         > > I downloaded ivy, copied the
> >         ivy-2.0.0-alpha2-incubating.jar to
> >         > > my /usr/share/ant/lib (where all the ant jars are) folder.
> >         Then I CD'd
> >         > > into
> >         > > the /apache-
> >         ivy-2.0.0-alpha2-incubating/src/example/build-a-ivy-repository
> >         folder, and ran: ant
> >         > > advanced
> >         > >
> >         > > It seems it has a problem looking up the antlib.xml from
> >         the xmlns.
> >         > > Here's the error:
> >         > >
> >         > > BUILD FAILED
> >         >
> >         > /home/jdoklovic/apps/apache-ivy-2.0.0-alpha2-incubating
> /src/example/build-a-ivy-
> >         > > repository/build.xml:36: Problem: failed to create task or
> >         type antlib:org.apache.ivy.ant:settings
> >         > > Cause: The name is undefined.
> >         > > Action: Check the spelling.
> >         > > Action: Check that any custom tasks/types have been
> >         declared.
> >         > > Action: Check that any <presetdef>/<macrodef> declarations
> >         have taken
> >         > > place.
> >         > >
> >         > > This appears to be an antlib declaration.
> >         > > Action: Check that the implementing library exists in one
> >         of:
> >         > >         -/usr/share/ant/lib
> >         > >         -/home/jdoklovic/.ant/lib
> >         > >         -a directory added on the command line with the
> >         -lib argument
> >         > >
> >         > >
> >         > >
> >         > >
> >         > >
> >         > > Here's the top of the build file:
> >         > >
> >         > >
> >         > >
> >         > > <project name="ivy-repository" default="basic"
> >         > > xmlns:ivy="antlib:org.apache.ivy.ant">
> >         > >     <property name="configuration-dir" value="config"/>
> >         > >     <property name="from-resolver" value="libraries"/>
> >         > >     <property name="to-resolver" value="sftp-repository"/>
> >         > >
> >         > >     <property name=" ivy.cache.dir"
> >         value="${basedir}/cache" />
> >         > >     <property name="dest.repo.dir"
> >         > > value="${basedir}/ivy-local-repository" />
> >         > >
> >         > >     <ivy:settings id=" basic.settings"
> >         > > file="${configuration-dir}/ivysettings-basic.xml"/>
> >         > >     <ivy:settings id="maven1.settings"
> >         > > file="${configuration-dir}/ivysettings- maven1.xml"/>
> >         > >     <ivy:settings id="maven2.settings"
> >         > > file="${configuration-dir}/ivysettings-maven2.xml"/>
> >         > >     <ivy:settings id="advanced.settings "
> >         > > file="${configuration-dir}/ivysettings-advanced.xml"/>
> >         > >
> >         > >
> >         > >
> >         > > Any ideas?
> >         > >
> >         > > Thanks,
> >         > >
> >         > > - Jonathan
> >         >
> >         >
> >
> >
> >
> >
> > --
> > Xavier Hanin - Independent Java Consultant
> > http://xhab.blogspot.com/
> > http://ant.apache.org/ivy/
> > http://www.xoocode.org/
>



-- 
Xavier Hanin - Independent Java Consultant
http://xhab.blogspot.com/
http://ant.apache.org/ivy/
http://www.xoocode.org/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message