ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lance Weber <la...@alfheimstudios.com>
Subject Re: Problem using Ant+Ivy builds from within Eclipse
Date Mon, 19 Nov 2007 22:53:11 GMT

Thanks for the fast response!

I do have it configured to use the external ANT_HOME, and I went and
double-checked all the settings under both Preferences and the project's ant
builder. I still get the same error...


jonathan doklovic wrote:
> 
> Are you using the eclipse version of ant or your ant home?
> I'd try going into eclipse: Window>Preferences>Ant>Runtime, click on the
> Ant Home... button and point it to your external ant home.
> This should make eclipse use your installed ant (and it's lib folder)
> instead of it's built-in version of ant.
> 
> - Jonathan
> 
> On Mon, 2007-11-19 at 14:37 -0800, Lance Weber wrote:
>> Hey folks, I'm trying to setup an Eclipse project to use an ant+ivy
>> script as
>> a builder. The script works fine outside of Eclipse, but as a builder, I
>> keep getting the following error when ant tries to run the <ivy:settings
>> id="ivy.instance"/> task:
>> 
>> jar:file:C:/work/tools/apache-ant-1.7.0/lib/ivy-2.0.0-alpha2-incubating.jar!/org/apache/ivy/ant/antlib.xml:21:
>> typedef A class needed by class org.apache.ivy.ant.IvyAntSettings cannot
>> be
>> found: org/apache/tools/ant/types/DataType
>> 
>> I'm using Eclipse 3.3, JDK6, Ant 1.7, Ivy 2.0alpha2, and IvyDE 1.3
>> 
>> Any help/pointers would be greatly appreciated! 
> 
> 

-- 
View this message in context: http://www.nabble.com/Problem-using-Ant%2BIvy-builds-from-within-Eclipse-tf4839966.html#a13847314
Sent from the ivy-user mailing list archive at Nabble.com.


Mime
View raw message