I had this same issue when working with the Hello tutorial.  I've seen other threads that say that it is fixed in the SVN repository.   That doesn't really do much good.  I think the point of having a website is to make it convenient for its users.  Having to look for components of a system in other places is not convenient.

I would think that you would want to get this released as soon as possible.  The Hello tutorial is the place where a lot of people go to learn about IVY and when it doesn't work it will either discourage them and even might make Ivy like its still not ready for production since the tutorial doesn't even work.

Dennis

Gilles Scokart wrote:
I guess it is actually the <packaging>bundle</packaging> present in the
pom.xml [1]

I don't know what it means.  It is not described in the description of the
pom [2].
Up to now we were considering that the packaging is actually the extension.
If this pom is correct, it is not.


[1]
http://repo1.maven.org/maven2/org/apache/camel/camel-script/1.2.0/camel-script-1.2.0.pom
[2] http://maven.apache.org/pom.html

Gilles

2007/10/24, kukusz <luke.majewski@gmail.com>:
  
This seems to be a very simple problem that I am having trouble tracking
down.  I have downloaded the tutorial and it works great.  Now when I try
to
use this for my own dependencies I start seeing some issues.  One of the
things I am looking for is the apache camel-script jar.  Here is the POM
dependency:

<dependency>
    <groupId>org.apache.camel</groupId>
    <artifactId>camel-script</artifactId>
    <version>1.2.0</version>
</dependency>


So I have this in my ivy.xml:

<ivy-module version="2.0">
        <info organisation="test" module="test" />
        <dependencies>
                <dependency org="org.apache.camel" name="camel-script"
rev="1.2.0" />
        </dependencies>
</ivy-module>

When I run retrieve, I see:

[ivy:retrieve]  ==== public: tried
[ivy:retrieve]

http://repo1.maven.org/maven2/org/apache/camel/camel-script/1.2.0/camel-script-1.2.0.bundle

There must be some setting that I am missing, why is it looking for a
*.bundle and not fetching the JAR in that location?  Pointing me to the
relevant documentation explaining this is a good starting point.

Thank you!
--
View this message in context:
http://www.nabble.com/Not-Retrieving-Some-JARs-tf4686265.html#a13392538
Sent from the ivy-user mailing list archive at Nabble.com.