ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles Scokart" <gscok...@gmail.com>
Subject Re: published artifacts not found with ant task
Date Wed, 17 Oct 2007 19:23:14 GMT
There is a few issues about the handling of the relative paths.  You can
look (and maybe vote) to https://issues.apache.org/jira/browse/IVY-387 or on
of the related issue.

Gilles

2007/10/17, Jing Xue <jingxue@digizenstudio.com>:
>
> On Wed, Oct 17, 2007 at 11:00:57AM +0200, Tom Baeyens wrote:
> [snip]
> > <ant dir="../enterprise" target="publish" inheritall="false" />
> [snip]
> >   [publish] missing artifact [ jbpm | enterprise | snapshot
> > ]/pvm-enterprise-cfg.jar[jar]:
> >   [publish]   target\pvm-enterprise-cfg.jar file does not exist
> >   [publish] missing artifact [ jbpm | enterprise | snapshot
> >   ]/pvm-enterprise.jar[jar]:
> >   [publish]   target\pvm-enterprise.jar file does not exist
> [snip]
> > When the same publish target is called directly in the right build file,
> it
> > works fine.  Only when it is called from another build file with the ant
> > task, it fails.
> >
> > I've tried various combinations of specifying the inheritall and
> > inheritrefs attributes in the ant task.  Also I tried the dir attribute
> in
> > various ways.
>
> I don't think either of those attributes changes how relative paths(e.g.
> thhe one you likely are using for artifact pattern when calling
> ivy:publish) are handled in an ant call. Maybe try somehow form an
> absolute path for the artifact pattern?
>
> HTH.
> --
> Jing Xue
>



-- 
Gilles SCOKART

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message