ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Hanson <notus...@djhanson.net>
Subject Re: Not Retrieving Some JARs
Date Thu, 25 Oct 2007 12:03:28 GMT
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
  <title></title>
</head>
<body bgcolor="#ffffff" text="#000000">
I had this same issue when working with the Hello tutorial.&nbsp; I've seen
other threads that say that it is fixed in the SVN repository.&nbsp;&nbsp; That
doesn't really do much good.&nbsp; I think the point of having a website is
to make it convenient for its users.&nbsp; Having to look for components of
a system in other places is not convenient.<br>
<br>
I would think that you would want to get this released as soon as
possible.&nbsp; The Hello tutorial is the place where a lot of people go to
learn about IVY and when it doesn't work it will either discourage them
and even might make Ivy like its still not ready for production since
the tutorial doesn't even work.<br>
<br>
Dennis<br>
<br>
Gilles Scokart wrote:
<blockquote
 cite="mid:e9d8a2610710250214v6cb5003fm11274ceed8845328@mail.gmail.com"
 type="cite">
  <pre wrap="">I guess it is actually the &lt;packaging&gt;bundle&lt;/packaging&gt;
present in the
pom.xml [1]

I don't know what it means.  It is not described in the description of the
pom [2].
Up to now we were considering that the packaging is actually the extension.
If this pom is correct, it is not.


[1]
<a class="moz-txt-link-freetext" href="http://repo1.maven.org/maven2/org/apache/camel/camel-script/1.2.0/camel-script-1.2.0.pom">http://repo1.maven.org/maven2/org/apache/camel/camel-script/1.2.0/camel-script-1.2.0.pom</a>
[2] <a class="moz-txt-link-freetext" href="http://maven.apache.org/pom.html">http://maven.apache.org/pom.html</a>

Gilles

2007/10/24, kukusz <a class="moz-txt-link-rfc2396E" href="mailto:luke.majewski@gmail.com">&lt;luke.majewski@gmail.com&gt;</a>:
  </pre>
  <blockquote type="cite">
    <pre wrap="">
This seems to be a very simple problem that I am having trouble tracking
down.  I have downloaded the tutorial and it works great.  Now when I try
to
use this for my own dependencies I start seeing some issues.  One of the
things I am looking for is the apache camel-script jar.  Here is the POM
dependency:

&lt;dependency&gt;
    &lt;groupId&gt;org.apache.camel&lt;/groupId&gt;
    &lt;artifactId&gt;camel-script&lt;/artifactId&gt;
    &lt;version&gt;1.2.0&lt;/version&gt;
&lt;/dependency&gt;


So I have this in my ivy.xml:

&lt;ivy-module version="2.0"&gt;
        &lt;info organisation="test" module="test" /&gt;
        &lt;dependencies&gt;
                &lt;dependency org="org.apache.camel" name="camel-script"
rev="1.2.0" /&gt;
        &lt;/dependencies&gt;
&lt;/ivy-module&gt;

When I run retrieve, I see:

[ivy:retrieve]  ==== public: tried
[ivy:retrieve]

<a class="moz-txt-link-freetext" href="http://repo1.maven.org/maven2/org/apache/camel/camel-script/1.2.0/camel-script-1.2.0.bundle">http://repo1.maven.org/maven2/org/apache/camel/camel-script/1.2.0/camel-script-1.2.0.bundle</a>

There must be some setting that I am missing, why is it looking for a
*.bundle and not fetching the JAR in that location?  Pointing me to the
relevant documentation explaining this is a good starting point.

Thank you!
--
View this message in context:
<a class="moz-txt-link-freetext" href="http://www.nabble.com/Not-Retrieving-Some-JARs-tf4686265.html#a13392538">http://www.nabble.com/Not-Retrieving-Some-JARs-tf4686265.html#a13392538</a>
Sent from the ivy-user mailing list archive at Nabble.com.


    </pre>
  </blockquote>
  <pre wrap=""><!---->

  </pre>
</blockquote>
</body>
</html>

Mime
View raw message