ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Fleming" <colin.mailingl...@gmail.com>
Subject Re: Occasional long Ivy pauses?
Date Mon, 27 Aug 2007 18:31:37 GMT
Hi Gilles,

I'm not sure this is the problem - I have one right now, and it's
actually doing an ivy:info:

ivy.configure:

variables:
 [ivy:info] :: Ivy 2.0.0-alpha2-incubating - 20070712142751 ::
http://incubator.apache.org/ivy/ ::

It's been sitting there for at least 3-4 minutes now. Also even if it
is some problem with our remote repo,  the server is in the next room
and it's not slow for anything else.

Cheers,
Colin

On 26/08/07, Gilles Scokart <gscokart@gmail.com> wrote:
> Even when everything is in your cache, there are still some cases when
> ivy has to look on the repository.  For example, if your are using
> some of the x.latest, or version ranges.
> It is possible that it is one of your repository that occasionally
> took a long time to respond.
>
> Gilles
>
> 2007/8/25, Colin Fleming <colin.mailinglist@gmail.com>:
> > Hi all,
> >
> > We're in the process of migrating our build to Ivy, and we've noticed
> > that occasionally Ivy will pause for an extremely long time (minutes)
> > doing a resolve. This is in a build where everything is in either the
> > cache or a local repo, it shouldn't need to be going to the network.
> > If I break out and re-run the build it works fine. Has anyone
> > experienced this? Is there anything I can do to diagnose it?
> > Unfortunately since it's not repeatable it's not easy to always have
> > -debug on, the output is huge.
> >
> > Any help appreciated,
> > Colin
> >
>
>
> --
> Gilles SCOKART
>

Mime
View raw message