ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles Scokart" <gscok...@gmail.com>
Subject Re: Trying to run first build.xml (go example)
Date Tue, 31 Jul 2007 05:31:50 GMT
Well, I would say that you should read the tutorials.  They didn't
run, but still illustrates the concept, and the different things you
can do with ivy.

You should also have a look to the documention.

Then, start to write your build. And ask here if you have problems.

Gilles

2007/7/30, Chris Hane <chris@itsolut.com>:
> No problem.  Could you write up at least in email the couple of steps I
> need to get the alpha2 working?  I would like to start using the new
> version of Ivy but need a little direction.
>
> Also, I'm using eclipse 3.3 rather than the command line.
>
> Thanks,
> Chris...
>
>
> Gilles wrote:
>  > We have some problems with the tutorials.  They have not been updated for
>  > the 2.0 release.  It is on our plan to clean that for the next
>  > intermediary release (2.0-beta1).
>  >
>  > Moreover, it seems that we have some regression demonstrated by our
>  > tutorials :-(
>  >
>  >Gilles
>
> Chris Hane wrote:
> > When I run the go build.xml I get a couple of errors:
> >
> > 1) the downloadable file does not exist
> > [get] Error opening connection java.io.FileNotFoundException:
> > http://people.apache.org/~xavier/ivy/2.0.0-alpha-2-incubating/ivy.jar
> >
> >
> >
> > 2) if I download and install the ivy.jar (2.0.0-alpha-2) into the ivy
> > directory and run the go build.xml I get the following error:
> >
> > Buildfile: C:\data\source\ivy-test\go-ivy.build.xml
> > install-ivy:
> >      [echo] installing ivy...
> > generate-src:
> > go:
> >      [echo] using ivy to resolve commons-lang 2.1...
> > [ivy:cachepath] :: Ivy 2.0.0-alpha2-incubating - 20070712142751 ::
> > http://incubator.apache.org/ivy/ ::
> > [ivy:cachepath] No ivy:settings found for the default reference
> > 'ivy.instance'.  A default instance will be used
> > [ivy:cachepath] no settings file found, using default...
> > [ivy:cachepath] :: loading settings :: url =
> > jar:file:/C:/data/source/ivy-test/ivy/ivy.jar!/org/apache/ivy/core/settings/ivysettings.xml
> >
> >
> > BUILD FAILED
> > C:\data\source\ivy-test\go-ivy.build.xml:83: impossible to resolve
> > dependencies: resolve failed - see output for details
> >
> > Total time: 875 milliseconds
> >
> >
> > Chris....
> >
>


-- 
Gilles SCOKART

Mime
View raw message