ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles Scokart" <gscok...@gmail.com>
Subject Re: Trying to run first build.xml (go example)
Date Mon, 30 Jul 2007 18:31:15 GMT
For your first problem, I think you find the right workaround.

For your second problem, you can change the cachepath, and use :

<ivy:cachepath organisation="commons-lang" module="commons-lang"
revision="2.1" conf="default" pathid="lib.path.id" inline="true"/>

I changed the organisation, and I added the conf="default'.

It has to be updated because we are now using maven2 repository
instead of ivyrep as default repository.  And inside the maven
repository commons-lang is under the commons-lang organisation.

The conf="default" should be added because by default ivy will take
all configuration defined in the metadata found on the repository.
And  one of those configuration is the test configuration which is
interpretted as a private configuration.

Gilles

2007/7/30, Chris Hane <chris@itsolut.com>:
> When I run the go build.xml I get a couple of errors:
>
> 1) the downloadable file does not exist
> [get] Error opening connection java.io.FileNotFoundException:
> http://people.apache.org/~xavier/ivy/2.0.0-alpha-2-incubating/ivy.jar
>
>
>
> 2) if I download and install the ivy.jar (2.0.0-alpha-2) into the ivy
> directory and run the go build.xml I get the following error:
>
> Buildfile: C:\data\source\ivy-test\go-ivy.build.xml
> install-ivy:
>       [echo] installing ivy...
> generate-src:
> go:
>       [echo] using ivy to resolve commons-lang 2.1...
> [ivy:cachepath] :: Ivy 2.0.0-alpha2-incubating - 20070712142751 ::
> http://incubator.apache.org/ivy/ ::
> [ivy:cachepath] No ivy:settings found for the default reference
> 'ivy.instance'.  A default instance will be used
> [ivy:cachepath] no settings file found, using default...
> [ivy:cachepath] :: loading settings :: url =
> jar:file:/C:/data/source/ivy-test/ivy/ivy.jar!/org/apache/ivy/core/settings/ivysettings.xml
>
> BUILD FAILED
> C:\data\source\ivy-test\go-ivy.build.xml:83: impossible to resolve
> dependencies: resolve failed - see output for details
>
> Total time: 875 milliseconds
>
>
> Chris....
>


-- 
Gilles SCOKART

Mime
View raw message