ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier Hanin" <xavier.ha...@gmail.com>
Subject Re: Unresolved dependencies - spring-context
Date Tue, 03 Jul 2007 09:46:33 GMT
On 7/3/07, hezjing <hezjing@gmail.com> wrote:
>
> I guess the task below is good enough to clean the cache?
>
> <target name="clean-cache">
> <delete dir="${user.home}/.ivy/cache" />
> </target>


Yes, this is good enough if you don't specify another cache location in your
settings.

Well, the problem still exist after I cleaned the cache.


Is it exactly the same problem? If it is, it's strange, because the bug
fixed in trunk is sporadic, so it's very unlikely to happen twice at the
same location. Maybe something else...

So I guess
> the only option left is to use the trunk ... which unfortunately, I'm
> not a Subversion user  :-(


I have a recent non official version here:
http://www.xoocode.org/downloads/tools/ivy/ivy.jar

It has been built from trunk on june the 29th, and include the fix. Feel
free to give it a try.

Xavier

On 7/3/07, Xavier Hanin <xavier.hanin@gmail.com> wrote:
> > On 7/3/07, hezjing <hezjing@gmail.com> wrote:
> > >
> > > Hi
> > >
> > > Based on
> > >
> http://mvnrepository.com/artifact/org.springframework/spring-context/2.0.4
> > > ,
> > >
> > > <dependency>
> > > <groupId>org.springframework</groupId>
> > > <artifactId>spring-context</artifactId>
> > > <version>2.0.4</version>
> > > </dependency>
> > >
> > >
> > > I created below Ivy dependency,
> > >
> > > <dependency org="org.springframework" name="spring-context" rev="2.0.4"
> />
> > >
> > >
> > > When run, it gives the following error
> > >
> > >          ::::::::::::::::::::::::::::::::::::::::::::::
> > >          ::          UNRESOLVED DEPENDENCIES         ::
> > >          ::::::::::::::::::::::::::::::::::::::::::::::
> > >          :: [ org.springframework | spr | 2.0.4 ]: not found
> > >          ::::::::::::::::::::::::::::::::::::::::::::::
> > >
> > >
> > >
> > > Did I overlook anything this time?
> >
> >
> > No, you just ran into an Ivy bug:
> > https://issues.apache.org/jira/browse/IVY-524
> >
> > This bug is fixed on current trunk, so you can either try the trunk or
> clean
> > your cache (cleaning xml metadata is enough, you don't need to remove
> the
> > jars) and try again. Note that even with the trunk you will have to
> clean
> > your cache, since the badly parsed pom is now stored in your ivy cache.
> >
> > Xavier
> >
> > --
> > >
> > > Hez
> > >
> >
> >
> >
> > --
> > Xavier Hanin - Independent Java Consultant
> > Creator of Ivy, xooki and xoocode.org
> > More about me: http://xhab.blogspot.com/
> >
>
>
> --
>
> Hez
>



-- 
Xavier Hanin - Independent Java Consultant
Creator of Ivy, xooki and xoocode.org
More about me: http://xhab.blogspot.com/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message